[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: octave build issue -- error in fltk-backend.

From: Kai Habel
Subject: Re: octave build issue -- error in fltk-backend.
Date: Thu, 04 Nov 2010 17:55:23 +0100
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100914 SUSE/3.1.4 Lightning/1.0b2 Thunderbird/3.1.4

 On 18.08.2010 01:08, Jordi Gutiérrez Hermoso wrote:
On 17 August 2010 12:17, crakarjax<address@hidden>  wrote:
What was the solution to your initial problem?  I am seeing the same exact
compilation error right now.  Thanks!
On 17 August 2010 17:38, Alonso Escobar<address@hidden>  wrote:
Me too!, I've got the same problem. I'm running on a:
Hm. It appears I inadvertently replied privately. How
embarrassing. Below is what I responded to the original

---------- Forwarded message ----------
From: Jordi Gutiérrez Hermoso<address@hidden>
Date: 2010/8/2
Subject: Re: octave build issue -- error in fltk-backend.
To: Imam Toufique<address@hidden>

On 1 August 2010 22:00, Imam Toufique<address@hidden>  wrote:
I am having difficulties building octave where compilation failing

Below is my build environment:

gcc 4.5.0, gfortran 4.5.0
OS :  SuSE Linux Enterprise Server 10, 64-bit
fltk:  1.3.x-r7677

even if I pass --without-framework-opengl option to configure, the
build fails.

Below is the build log:

[gargantuan log snipped out]
can you please shed some light into this?  I tried running the build
with Intel C compiler, the build fails at the same place.
That's quite the messy compilation output... but I see you're using
FLTK 1.3, which is a development snapshot of FLTK. The stable FLTK
releease is 1.1. Have you tried building with that instead? It's what
I use to build. My guess is that FLTK 1.3 must be defining some macro
that happens to conflict with Octave.

Help-octave mailing list

I know this thread is pretty old, so this is mainly for people getting the same compilation error.

The problems seems to be that fltk1.3 includes X11/X.h. There is the following definition

/* Polygon shapes */

#define Complex                        0       /* paths may intersect */
#define Nonconvex 1 /* no paths intersect, but not convex */
#define Convex                  2       /* wholly convex */

this collides with liboctave/oct-cmplx.h:

#include <complex>

typedef std::complex<double> Complex;
typedef std::complex<float> FloatComplex;

As a workaround I have changed in X.h Complex to _Complex. After that I could compile octave again.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]