[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: missing text on plots

From: Ben Abbott
Subject: Re: missing text on plots
Date: Tue, 09 Nov 2010 09:12:36 +0800

On Nov 9, 2010, at 8:47 AM, Amirali Abdullah wrote:

> On Mon, Nov 8, 2010 at 5:42 PM, Ben Abbott <address@hidden> wrote:
>> On Nov 9, 2010, at 2:44 AM, amirali1985 wrote:
>> > Hi there. I'm using Octave 3.2.3 on Ubuntu 10.04. Whenever I use plot() on
>> > Octave, my figures have absolutely no text on the axes, no numbering 
>> > visible
>> > on the axes tic marks, no title, etc. I have tried the xlabel/ylabel/title
>> > functions, but no text is produced. (The legend command does work though,
>> > and the curves themselves are fine, albeit without text).
>> >
>> > No error messages or warnings are generated, and when I checked gnuplot
>> > independently, running it outside octave, no such errors were produced. Are
>> > there any ideas on what might be wrong, or at least what I should be
>> > checking out? I'm sorry if I'm missing something obvious in the
>> > documentation or forums; a cursory search didn't turn up any mention of 
>> > this
>> > specific problem.
>> I've not seen this before, but suggest you first verify that gnuplot works 
>> correctly. Pease ...
>> (1) run gnuplot
>> (2) type "plot sin(x)"
>> Are the tickmark labeled correctly?
>> Ben
> Thank you for the response Ben. As I mentioned earlier, I tried running from 
> gnuplot outside octave. When I open gnuplot, and type "plot(sin(x))", 
> everything displays correctly with tic-marks. Is there any more information I 
> could provide?
> Thanks,
> Amir.

Opps ... sorry I missed your earlier comment on gnuplot.

I suggest you try setting your default font to something other than "*".

For example, you might try "Arial"

        set (0, "defaultaxesfontname", "Arial")
        set (0, "defaulttextfontname", "Arial")


reply via email to

[Prev in Thread] Current Thread [Next in Thread]