[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling octave for SuSE11.3 for image functionality

From: Martin Helm
Subject: Re: Compiling octave for SuSE11.3 for image functionality
Date: Sat, 8 Jan 2011 17:10:00 +0100
User-agent: KMail/1.13.5 (Linux/; KDE/4.5.5; x86_64; ; )

Am Samstag, 8. Januar 2011, 16:44:54 schrieb Enno Fennema:
> Before compiling I tried to get all packages as described by Bernhard
> Schoeps.
> I did not find packages hdf5-devel (hdf5 was ok), ftgl (libfgtgl2 and
> ftgl-devel ok) nor package qhull-2003 (again libqhull5 and
> libqhull5-devel ok). 'configure' looked ok, 'compile' looked ok.
> Ran 'run-octave' and basics worked. Now called
>    I = imread('image24.png');
> Now get:
> octave: magick/semaphore.c:525: LockSemaphoreInfo: Assertion
>      `semaphore_info != (SemaphoreInfo *) ((void *)0)' failed.
> panic: Aborted -- stopping myself...
> Aborted
> That is progress but not enough. Stuck again.
> PS. I am surprised that Schoeps suggests including both GraphicsMagick
> and ImageMagicks. I thought the two were competing and not necessarily
> compatible?? I am not sure which one I am actually using.
> Would appreciate any help.
> Enno

I think you run now into trouble with a too new version of graphicsmagick 
compared to the octave version.
Have  a look at this bug report for 3.2.4. At the end you find some patches 
which should solve your problem.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]