[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: font size and plot size

From: Ben Abbott
Subject: Re: font size and plot size
Date: Sun, 30 Jan 2011 12:07:01 -0500

On Jan 30, 2011, at 1:21 AM, Evan wrote:

> On Sun, Jan 30, 2011 at 1:21 PM, Ben Abbott <address@hidden> wrote:
>> On Jan 29, 2011, at 9:21 PM, Evan wrote:
>>> On Sun, Jan 30, 2011 at 10:09 AM, Ben Abbott <address@hidden> wrote:
>>>> On Jan 29, 2011, at 9:05 PM, Evan wrote:
>>>>> On Sun, Jan 30, 2011 at 7:37 AM, Ben Abbott <address@hidden> wrote:
>>>>>> I can confirm that when using the FLTK backend the text objects do 
>>>>>> respect their fontsize property for "-depslatexstandalone" output. 
>>>>>> However, the gnuplot version does not.
>>>>> That's exactly what I am asking for the gnuplot backend. I guess this
>>>>> can be easily fixed by just passing the fontsize option to the gnuplot
>>>>> epslatex terminal.
>>>> Unfortunately, my experience is that gnuplot does not change the fontsize. 
>>>> Let me know if your experience is different.
>>> The following text is taken from the help document for the epslatex
>>> terminal of gnuplot:
>>> In standalone mode, the font size is taken from the given font size in the
>>> `set terminal` command. To be able to use a specified font size, a file
>>> "size<size>.clo" has to reside in the LaTeX search path.  By default,
>>> 10pt, 11pt, and 12pt are supported.  If the package "extsizes" is
>>> installed, 8pt, 9pt, 14pt, 17pt, and 20pt are added.
>>> I have test to add something like "set terminal epslatex 20" to the
>>> gnuplot initialization file ".gnuplot", this does change the font size
>>> for "-depslatexstandalone" when printing in octave. So I think this
>>> can be easily added to print.m of octave.
>> You can experiment by using the drawnow() function.
>>        drawnow ("epslatex standalone", "test.tex", false, "")
>> The file contains the gnuplot commands.
>> If you modify the contents of, you can see the modified results by 
>> running gnuplot and typing "load"
>> Ben
> I tested the drawnow function, it seems that changing the first
> parameter of drawnow to "epslatex standalone font <fontsize>" will fix
> the problem.

Running the developer's sources, I see that the "-F:<fontsize>" option does 
pass the fontsize information to gnuplot.

Unfortunately, when I then run the result through LaTeX, I get the error below.

        ! Gnuplot Error: File `size18.clo' not found! Could not set font size.

        See the gnuplot documentation for explanation.
        Type  H <return>  for immediate help.

In this instance I tried "-F:18". Other fontsizes gave the same error. However, 
"-F:10", "-F:12", "-F:14", "-F:20" each gave the expected result.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]