[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make error: octave 3.4.0 building from source

From: Chethan S
Subject: Re: make error: octave 3.4.0 building from source
Date: Sun, 24 Apr 2011 21:35:51 +0530

Hi all!

I solved my problem this way. Its not actually the right way but it solved my problem. I installed 'octave3.2' from Ubuntu repository and then ran './configure' and 'make' for octave 3.4.0 installation from source. This time everything went fine with no errors.

Later I uninstalled 'octave3.2' and ran 'sudo make install' to install the latest version!

Thanks and regards,

Chethan S.

2011/4/24 Chethan S <address@hidden>
I think it is not the error mentioned there. As you might have seen, in my case after I ran make as LANG=C make that "egrep: Invalid range end" vanished. Also I don't see errors like
LC_ALL=de_DE.utf8 /usr/bin/texi2dvi /some/path/and/file.texi
/usr/bin/texi2dvi: cannot read .//some/path/and/file.texi, skipping.
as mentioned in that link.

Thanks and regards,

Chethan S.

2011/4/24 John W. Eaton <address@hidden>

On 23-Apr-2011, Jordi Gutiérrez Hermoso wrote:

| 2011/4/23 Chethan S <address@hidden>:
| > I tried running ./configure and this time with LANG=C make. Still I
| > encountered the same error:
| >
| > Making all in faq
| > make[3]: Entering directory
| > `/home/chethan/Applications/octave-3.4.0/doc/faq'
| >     MAKEINFO='/bin/sh
| > /home/chethan/Applications/octave-3.4.0/build-aux/missing --run makeinfo
| > -I .' \
| >     texi2dvi OctaveFAQ.texi
| > make[3]: *** [OctaveFAQ.dvi] Error 1
| > make[3]: Leaving directory `/home/chethan/Applications/octave-3.4.0/doc/faq'
| > make[2]: *** [all-recursive] Error 1
| > make[2]: Leaving directory `/home/chethan/Applications/octave-3.4.0/doc'
| > make[1]: *** [all-recursive] Error 1
| > make[1]: Leaving directory `/home/chethan/Applications/octave-3.4.0'
| > make: *** [all] Error 2
| >
| > except for "egrep: Invalid range end" which was missing!
| >
| Well, I'm mystified. There isn't an error there at all, so I wonder
| what make is seeing.
| At any rate, this is only about building the documentation. A bigger
| workaround is to not build the documentation at all. Disable it from
| the configure script.

Is the problem the same as the one reported here



reply via email to

[Prev in Thread] Current Thread [Next in Thread]