[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Octave 3.3.91 - impossible to install packages and built-in oct file

From: Andy Buckle
Subject: Re: Octave 3.3.91 - impossible to install packages and built-in oct files...
Date: Wed, 27 Apr 2011 12:18:44 +0100

On Tue, Apr 26, 2011 at 1:29 PM, constant31 <address@hidden> wrote:
> Hello,
> I installed Octave 3.2.4 from the official setup exe on Windows Vista. All
> the packages are installed and all work.
> However, after installing from a zip the 3.3.91 version from the site of
> Tatsuro Matsuoka:
> I tried to add packages to Octave. This was impossible and I'm very
> frustrated.
> I copied all the needed packages in the folder /share/octave/packages, each
> one with the defaul name after untaring the forge archive.
> When I type:
>  > pkg load optim  (for exemple), Octave says:
>  > warning: addpath: C:\Octave\3_3_91\share\octave\packages\miscella: No
> such file or directory
> Is like a stupid truncation of the path ....
> I tried to find WHERE Octave put the list of the folders added in the path
> with 'addpath' and 'savepath'... but impossible to find too.
> On the other hand, not only the packages is impossible to add, but the
> built-in libraries contained in the folder 'lib' (there are many precompiled
> oct files for some packages) too are impossible to add to Octave. Maybe one
> by one with 'addpath' but this seems a little bit stupid to do in this way,
> because there are so many.
> In Octave 3.2.4 these files are installed in the folder :
>  C:\Octave\3.2.4_gcc-4.4.0\libexec\octave\packages
> and are automatically recognized. The 3.3.91 version doesn't recognize them.
> After typing 'help numgradient' for exemple (a compiled function from the
> optim package), Octave says
>> error: help: `numgradient' not found
> Please help me or tell me where to read the corresponding info. Thank you by
> advance,
> Constant

I have not tried copying packages between installations. I guess you
would need to look carefully at what was needed to install a package.

have you tried getting new packages from sourceforge

and doing
pkg install foo.tar.gz

/* andy buckle */

reply via email to

[Prev in Thread] Current Thread [Next in Thread]