[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: strcat not found--MinGW

From: wahaj87
Subject: Re: strcat not found--MinGW
Date: Sat, 30 Apr 2011 15:49:47 -0700 (PDT)

Hi Daryl Lee 

Your program is very nice. I am learning from it. Here is simple solution
for your problem.

1 - I used this command to build the stand alone executable on vista and xp

mkoctfile -Lc:\Octave\lib -LC:\octave\include\octave-3.2.4\octave
--link-stand-alone test2.cpp -o test2

above command is little different from yours, I think some path is not seen
by octave compiler on my computer for lapack library, so I manually given
the library path.

Now I opened a command prompt, and cd to the directory where i have
test2.exe, and run it. The same error you mention pop up. You know why ? 
This is also a path problem. So to make it right quickly , I copied the
strcat.m from directroy "C:\Octave\share\octave\3.2.4\m\strings" to
directory where test2.exe exists. Run it again. Again two errors pop up ,
demanding max and find undefined. So I again copied max.oct and find.oct
from directory "C:\Octave\libexec\octave\3.2.4\oct\i686-pc-mingw32", to
directory where test2.exe exists. Now I run the test2.exe ! and wow it says
in output :

Good morning,Hero

tHAtS IT.--
View this message in context:
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]