[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

filtfilt error solved?

From: seektime
Subject: filtfilt error solved?
Date: Fri, 3 Feb 2012 08:16:14 -0800 (PST)


I'd like to use the filtfilt function in the signal proc. TB. Unfortunately,
running the example from help section throws the following error:

octave:129> [b, a]=butter(3, 0.1);
octave:130> t = 0:0.01:1.0;
octave:131> x=sin(2*pi*t*2.3)+0.25*randn(size(t));
octave:132> y = filtfilt(b,a,x);
error: filter: first dimension of SI must be of length max (length (a), 
length (b)) - 1
error: called from:
gnal-1.1.1\filtfilt.m at line 85, column 3

I read in a previous post that the problem lies with 'filter.m', but that
seemed to refer to ver. 3.4.2. I'm running Octave 3.4.3 (mingw). Is there's
a quick fix? Any ideas or solutions are highly welcome. 


View this message in context:
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]