[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help needed: 'fread' error (Octave 2.1.57): 'unable to find matching nat

From: Yaman.Aksu
Subject: Help needed: 'fread' error (Octave 2.1.57): 'unable to find matching native data type for uchar=>char'
Date: Tue, 28 Feb 2012 13:47:43 -0800 (PST)

I'm trying to use Octave 2.1.57 on RedHat to run a system of Matlab .m files
I had written. Ran into various error messages, was able to go past them
without asking for help (such as by using online info sources), but now I'm
running into a new error I could use direct help with:

Firstly, I know what I'm using is an old version, but note that the RedHat
version I'm using is similarly 4-5 years old also. Also, I was able to go
past several errors already, and so, I'd like to just continue to move
forward with porting my .m code -- for now I want to postpone the hassle of
a potentially necessary version upgrade as much as possible, even though I'm
experienced with software/OS installs and such. I'm not sure how I came to
have Octave on this RedHat machine, I think it was installed simply as part
of my installation of RedHat around 2006. 

The error is when 'fread' is invoked:
error: invalid data type specified
error: unable to find matching native type for uchar=>char
error: fread: invalid data type specified
error: evaluating if command near line 187, column 2

The line is:
    [text, foo1] = fread(fid, 'uchar=>char');

Changing the line to
    [text, foo1] = fread(fid, '*char');
gives the same error. (I tried this change just in case, to learn more about
the problem.)

I'm aware of the following past thread that discussed a very similar '*char'
problem. That thread provided a patch for that problem. But the error I'm
getting is different.

I looked online for Release Notes, to see whether  2.1.57 did not yet
(surprisingly) include sufficient support for 'char' and 'uchar' for
'fread'. I found this but it wasn't detailed enough:
If there are more detailed Release Notes than this, please point me to them.

What would you recommend for me to try with my existing installation
(2.1.57) to port the above problematic 'fread' line to Octave? What exactly
is the problem, do you know?? Is there a patch?? If so, could you provide
complete installation instructions for the patch? I see that the above
thread discussed a .cc file, for example. Will I have to compile code when
trying to go past this 'fread' problem? Please note that I'm not yet
familiar with the installation structure of Octave - all I know is that my
installation folder apparently is /usr/share/octave/2.1.57.

Thank you in advance.

Yaman Aksu, Ph.D.
Pennsylvania, USA
View this message in context:
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]