[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Just installed on WIn7 and segfault occurs

From: Nicholas Jankowski
Subject: Re: Just installed on WIn7 and segfault occurs
Date: Wed, 7 Nov 2012 15:25:52 -0500

On Wed, Nov 7, 2012 at 1:53 PM, Allan Smith <address@hidden> wrote:


From: address@hidden [mailto:address@hidden] On Behalf Of Nicholas Jankowski
Sent: 07 November 2012 17:10
To: Allan Smith
Cc: Octave users list
Subject: Re: Just installed on WIn7 and segfault occurs


On Wed, Nov 7, 2012 at 12:07 PM, Nicholas Jankowski <address@hidden> wrote:

On Wed, Nov 7, 2012 at 11:27 AM, Allan Smith <address@hidden> wrote:

I have just refurbed a computer to purely to run an Octave prog which may need to run for a long time.


I installed Win 7 and fully updated it.

I installed Jave RTE

I installed C++ dll

I installed the 7 zip program.

I downloaded the Octave3.6.1_gcc4.6.2_20120303,tz and uncompressed it into c:\octave

I downloaded the Octave3.6.1_gcc4.6.2_pkgs_20120303.7z file and uncompressed it into c:\octave

I copied the 2 shortcuts to my desktop.

I launched Octave – no problem

I carried out the re-builds:

pkg rebuild –auto

pkg rebuild –noauto ad windows

pkg rebuild –noauto nan

pkg rebuild –noauto gsl

pkg rebuild –auto java


all went well.

Closed and re-opened Octave – it started up and give a stack of ‘warnings’ then a prompt.


My Octave programme is in c:\test

octave:1>  cd c:\test

octave:2> ls

{ directory listing appears here – so all appears to be well}

octave:3> RUN_ALL

panic: Segmentation violation  --  stopping myself...

attempting to save variables to ‘octave-core’,,,

save to ‘octave-core’ complete


I tried running in XP compatible and Administrator modes – same problem

Dump is attached


Any advice would be appreciated.


Allan Smith



Help-octave mailing list

ok, since everything seems fine until you execute the script, what's in the RUN_ALL script?

Sorry, forgot to include the mailing list.

2nd question, is there a reason you used the 3.6.1 instead of 3.6.2 version?

maybe it's a bug that was fixed...

Thanks for the reply.


To answer your questions in reverse order.


Why 3.6.1?  Simply because when I searched for a version to download that is what came up in the search result.

I have now loaded 3.6.2 and the app now runs – so it must have been something that was fixed that caused the problem.

Either that or I messed something up on the first install – and didn’t make the same mistake this time.


So your advice on the availability of a newer version did the trick. Thanks.


The App? – Its a cost reduction exercise which compares the costs of parts from many vendors against a wanted list to find the cheapest solution.


Allan Smith

just bouncing to the list to complete the thread.  Glad it worked out. Only asked about the program itself in case it was some function buried in there that was the problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]