[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pkg problems

From: Terry Duell
Subject: Re: pkg problems
Date: Sun, 25 Nov 2012 08:53:02 +1100
User-agent: Opera Mail/12.11 (Linux)

Hello Carnë,

On Sat, 24 Nov 2012 15:01:25 +1100, Carnë Draug <address@hidden> wrote:

On 24 November 2012 04:48, Terry Duell <address@hidden> wrote:
Can someone please suggest the 'proper' process (assuming that there is one) that I should follow to get to an updated set of packages, so 'pkg' knows what it should know and Octave paths are correct?

My suggestion would be the following:

1 -  remove all packages installed from the repos.
2 - remove your ~/octave directory (well, make a copy of it somewhere
else in case in something goes wrong). This are your local
installation of packages.
3 - remove ~/.octave_packages (your database with locally installed packages)
4 - remove OCTAVE_HOME()/share/octave/packages and octave_config_info
("libdir")/octave/packages (get the value of OCTAVE_HOME and
octave_config_info ("libdir") from an Octave prompt). These are global
packages you may have installed as root
5 - remove OCTAVE_HOME()/share/octave/octave_packages (your database
for globally installed packages)

When you start Octave now, you should now have a clean start. It
should also be possible to rebuild the databases with "pkg rebuild"
but I never tried it.

OK, I followed the above to clean out all my packages and other files as suggested, then installed all the packages I required using 'pkg install -forge ...', and that has all gone well, although there were a Huge number of warnings when installing the control package, and a lesser number for odepkg, but I guess that OK, I have yet to test.

When I now start Octave I get many warnings (addpath) referring to old packages that were removed from my ~/octave dir. If I run 'path' none of these old paths are included in the output. All these old paths are included in my .octaverc file. Is there a simple way that these old paths can removed? I am assuming that as 'path' doesn't know about them I can't use 'rmpath()'.

Thanks for your help

Terry Duell

reply via email to

[Prev in Thread] Current Thread [Next in Thread]