[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Was Running Beautifully, Now Not?

From: Damian Harty
Subject: RE: Was Running Beautifully, Now Not?
Date: Tue, 2 Sep 2014 18:22:29 +0000

> Anyway, as far as I see, the problem is more about Ghostscript than Octave or 
> the
> handling of Ghostscript in Octave or whatsover. Maybe you are trying to plot 
> anything,
> Ghostscript cannot handle or so.

I've definitely formed the impression that it is a Ghostscript problem, I agree.

> Does this error occurs with any plot, you are trying to print?


  octave:4> t=0:1:100;
  octave:5> y=sin(t*2*pi/100);
  octave:6> plot(t,y)
  octave:7> print(1,'test1.jpg')
  Error: /undefined in nan
  Operand stack:
  Execution stack:
     %interp_exit   .runexec2   --nostringval--   --nostringval--   
--nostringval--   2   %stopped_push   --nostringval--
    --nostringval--   --nostringval--   false   1   %stopped_push   1932   1   
3   %oparray_pop   1931   1   3   %oparray_
  pop   --nostringval--   1915   1   3   %oparray_pop   1803   1   3   
%oparray_pop   --nostringval--   %errorexec_pop   .
  runexec2   --nostringval--   --nostringval--   --nostringval--   2   
%stopped_push   --nostringval--
  Dictionary stack:
     --dict:1179/1684(ro)(G)--   --dict:0/20(G)--   --dict:82/200(L)--   
  Current allocation mode is local
  Last OS error: No such file or directory
  GPL Ghostscript 9.07: Unrecoverable error, exit code 1

I take from this that it's not an issue with what specifically I am trying to 

> Did you try saveas as an alternative tp print?

Yes, I tried using saveas, it gives an identical message.

So this stuff definitely used to work for me without any difficulty. I have 
been using this script for many months now. Any clues as to what could have 
changed? My machine has gone through quite a stable period of late with not 
many changes to software etc, but clearly something has changed. Windows 7 64 
Bit, Octave 3.6.4 gcc 4.6.2.

I tried the -debug option, too:

   octave:14> print -djpg -debug test1.jpg
   Ghostscript command: 'C:\Octave\Octave3.6.4_gcc4.6.2\gs\bin/gswin32c.exe 
    -dTextAlphaBits=4 -dGraphicsAlphaBits=4 -r150x150 -dEPSCrop 
-sOutputFile=test1.jpg -'
   fltk-pipeline: 'C:\Octave\Octave3.6.4_gcc4.6.2\gs\bin/gswin32c.exe -dQUIET 
   tAlphaBits=4 -dGraphicsAlphaBits=4 -r150x150 -dEPSCrop 
-sOutputFile=test1.jpg -'

...but it means nothing to me.


CONFIDENTIAL: The information contained in this email communication is 
confidential information intended only for the use of the addressee. 
Unauthorized use, disclosure or copying of this communication is strictly 
prohibited and may be unlawful. If you have received this communication in 
error, please notify us immediately by return email and destroy all copies of 
this communication, including all attachments.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]