[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Just compiled 3.8.1 - Crash on loading an image

From: Carnë Draug
Subject: Re: Just compiled 3.8.1 - Crash on loading an image
Date: Sat, 20 Sep 2014 20:16:07 +0100

Please keep the mailing list CC'ed when replying. Also, I'm moving
this to the help mailing list.

On 20 September 2014 19:10, Paul B. Kellner <address@hidden> wrote:
> On 09/21/2014 12:57 AM, Carnë Draug wrote:
>> On 20 September 2014 16:12, kellnerp <address@hidden> wrote:
>>> I just compiled Octave 3.8.1 on my Core2duo notebook under Ubuntu 12.10.
>>> When
>>> I loaded the image package and tried to run a script I had Octave crashed
>>> (exit code 9). I suspected the image I was loading was the culprit so I
>>> tried loading it from the command line. I got this reading the image:
>>>>> I = imread('IMG_20140905_094102.jpg');
>>> warning: your version of GraphicsMagick limits images to 8 bits per pixel
>>> This image is only 5.3M.
>>> Then I executed this command:
>>>>> figure(1); image(I);
>>> panic: Bus error -- stopping myself...
>>> attempting to save variables too...
>>> and then exit code 7 on the console from which I started Octave.
>>> ~/Downloads/octave-3.8.1$ octave3.8 --force-gui
>>> octave exited with signal 7
>>> How should I proceed on something like this?
>> 1) the problem is not in loading the image, it is on displaying it.
>> What graphics toolkit are  you using?
>> 2) without the actual image to replicate it, we cannot try it ourselves.
>> 3) why did you build it from source? Have you tried Octave's PPA [1]?
>> Carnë
>> [1]
> 1) I am not sure how determine the graphics toolkit. If you are refering to
> GraphicsMagick++ then I am using the repository version.

No. GraphicsMagick is just what is used to read the image file. Once
the image has been read, GraphicsMagick has nothing to do with
anything, all you have is a matrix. The problem is somehow on the
display of that matrix. Just run "graphics_toolkit" at the Octave

> 2. After killing octave with CTRL C the gui now refuses to come up, even
> after a reboot of the system.
> This led me to try the same steps without the GUI. Without the GUI octave
> will display the image.
> 3) I built from source because the repository version of octave has an image
> package that will not run the scripts I am trying to use.

Those things are unrelated. You can install Octave 3.8.1 from the PPA
and then install the latest version of the image package from the
octave prompt using. You will need to install liboctave-dev.

> The build instructions came from here:

This also recommends that you use the Octave PPA. This blog post was
written in the time between the 3.8 release and the update to the PPA.

> The script I am trying to run uses imresize which will not load the image
> file. But this is probably a different issue.

What does load image means? imresize resizes a matrix, its input is a
matrix and not a file.

> The images are from a cell phone camera.sRGB and I'm pretty sure 8 bit
> quanta.

You're still not sharing the problematic image file. Please give us a
way to replicate your problem, we can't help you otherwise. Anyway,
try the Octave PPA first.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]