[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: octcdf and netcdf crash errors

From: Alexander Barth
Subject: Re: octcdf and netcdf crash errors
Date: Fri, 20 Feb 2015 21:10:42 +0100

On Mon, Jan 5, 2015 at 12:14 AM, James Luffman <address@hidden> wrote:
Hi There, I am having some problems with the octcdf and netcdf packages - any help would be appreciated.

I have just been through this helpful guide by Alexander Barth:

Basically, regardless of whether I use octcdf or netcdf, upon calling any netcdf handling functions, I get this and a crash:
panic: Segmentation violation -- stopping myself....

Here is some info on what I'm running and what I've tried:
-Running Octave 3.8.1 on Windows 8 64 bit, and am getting the crash error in both GUI and non-GUI mode
-Have installed netcdf 4.3.2, have modified windows path to include netcdf directories, and can successfully call netcdf functions (eg ncdump) from the windows command line, so netcdf appears to be working fine
-Have tried both octcdf 1.1.7 and netcdf 1.0.4, installed using 'pkg install -verbose -auto -forge <pkgname>'

My goal is simply to be able to read netCDF files into Octave arrays.

Dear  James,

For some reasons I must have overlooked your mail. Sorry for the latest response.

I do not have any experience in debugging application under windows as I use Linux. But on my windows 8.1 machine (also 64-bit) the netcdf package works with octave 3.8.2 (downloaded from here

I can run the test_netcdf script without error (I get just a warning that a temporary file cannot be deleted; probably I forgot to close the file in the test-script. I will fix this.).

Can you try the following:
1. upgrade to octave 3.8.2 (unfortunately the server seem to be down now!)
2. run the test_netcdf script and send me its output if you get an error message.

Netcdf is integrated in octave-mxe (, there is no need to install you own version.

I hope this helps,

>> pkg install -verbose -forge netcdf
mkdir (C:\Users\ALEXAN~1\AppData\Local\Temp\oct-3)
untar (C:\Users\Alexander Barth\netcdf-1.0.4.tar.gz, C:\Users\ALEXAN~1\AppData\Local\Temp\oct-3)
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.exe
checking for suffix of executables... .exe
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for mkoctfile... C:/Octave/Octave-3.8.2/bin/mkoctfile-3.8.2.exe
checking for F77_FUNC... yes
checking for octave... C:/Octave/Octave-3.8.2/bin/octave-3.8.2.exe
checking for OCTAVE_VERSION in Octave... 3.8.2
checking for octave_config_info('canonical_host_type') in Octave... i686-w64-mingw32
checking for octave_config_info('SHLEXT') in Octave... dll
checking whether ln -s works... no, using cp -pR
checking for ranlib... ranlib
checking for strip... strip
checking for nc-config... nc-config
configure: creating ./config.status
config.status: creating Makeconf

  "$prefix" is C:/Octave/Octave-3.8.2/share/octave/packages/netcdf-1.0.4
  "$exec_prefix" is ${prefix}

octave commands will install into the following directories:
   m-files:   /home/benutzer/mxe-octave/usr/i686-w64-mingw32/share/octave/3.8.2/site/m/octave-forge
   oct-files: /home/benutzer/mxe-octave/usr/i686-w64-mingw32/lib/octave/3.8.2/site/oct/i686-w64-mingw32/octave-forge
   binaries:  /home/benutzer/mxe-octave/usr/i686-w64-mingw32/libexec/octave/3.8.2/site/exec/i686-w64-mingw32
   m-files:   /home/benutzer/mxe-octave/usr/i686-w64-mingw32/share/octave/3.8.2/site/octave-forge-alternatives/m
   oct-files: /home/benutzer/mxe-octave/usr/i686-w64-mingw32/lib/octave/3.8.2/site/octave-forge-alternatives/oct/i686-w64-mingw32

shell commands will install into the following directories:
   binaries:  ${exec_prefix}/bin
   man pages: ${datarootdir}/man
   libraries: ${exec_prefix}/lib
   headers:   ${prefix}/include

octave-forge is configured with
   octave:      C:/Octave/Octave-3.8.2/bin/octave-3.8.2.exe (version 3.8.2)
   mkoctfile:   C:/Octave/Octave-3.8.2/bin/mkoctfile-3.8.2.exe for Octave 2
   netCDF compiler flags:  -I/home/benutzer/mxe-octave/usr/i686-w64-mingw32/include -I/home/benutzer/mxe-octave/usr/i686-w64-mingw32/include
   netCDF libraries:  -L/home/benutzer/mxe-octave/usr/i686-w64-mingw32/lib -lnetcdf

make: Entering directory `/tmp/oct-3/netcdf/src'
mkoctfile -I/home/benutzer/mxe-octave/usr/i686-w64-mingw32/include -I/home/benutzer/mxe-octave/usr/i686-w64-mingw32/include -L/home/benutze
r/mxe-octave/usr/i686-w64-mingw32/lib -lnetcdf
make: Leaving directory `/tmp/oct-3/netcdf/src'
copyfile C:\Users\ALEXAN~1\AppData\Local\Temp\oct-3\netcdf\src\__netcdf__.oct C:\Users\ALEXAN~1\AppData\Local\Temp\oct-3\netcdf\inst\i686-w64-mingw32-api
For information about changes from previous versions of the netcdf package, run 'news netcdf'.
>> pkg list
Package Name  | Version | Installation directory
      divand *|   1.1.2 | C:\Octave\Octave-3.8.2\share\octave\packages\divand-1.1.2
   financial *|   0.4.0 | C:\Octave\Octave-3.8.2\share\octave\packages\financial-0.4.0
          io *|   2.2.6 | C:\Octave\Octave-3.8.2\share\octave\packages\io-2.2.6
      netcdf  |   1.0.4 | C:\Octave\Octave-3.8.2\share\octave\packages\netcdf-1.0.4
>> pkg load netcdf
>> test_netcdf
Using NetCDF library version "4.3.2 of Sep  4 2014 14:46:33 $"
run test_netcdf_constant..............   OK
run test_netcdf_create................   OK
run test_netcdf_low_level_interface...   OK
run test_netcdf_unlim.................   OK
run test_netcdf_datatypes.............   OK
run test_netcdf_scalar_variable.......   OK
run test_netcdf_attributes............ warning: delete: C:\Users\ALEXAN~1\AppData\Local\Temp\ Permission denied
run test_netcdf_high_level_interface..   OK
run test_netcdf_ncwriteschema.........   OK
run test_netcdf_ncwriteschema_unlim...   OK
run test_netcdf_ncwriteschema_chunking   OK
run test_netcdf_ncwriteschema_group...   OK

reply via email to

[Prev in Thread] Current Thread [Next in Thread]