[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: octave 4.2 on mac os 10.12 using Homebrew

From: Sunil Shah
Subject: Re: octave 4.2 on mac os 10.12 using Homebrew
Date: Sat, 8 Oct 2016 10:48:59 -0700

On Sat, Oct 8, 2016 at 6:43 AM, Sebastian <address@hidden> wrote:
>> On Oct 8, 2016, at 12:38 AM, SunilShah <address@hidden> wrote:
>> brew installl octave fails on mac os 10.12 because dependency qt5 does not
>> work on os 10.12.
>> Is there a workaround for installing octave on os 10.12 using Homebrew?
>> Sunil
> This is curious. I’m running Homebrew’s GNU Octave, version 4.2.0-rc2, on OS X 10.12. I upgraded from version 4.0.3_4, which, if I remember correctly, was compiled with qt5. Everything seems to work fine. I don’t know whether I am using qt5 or not, but I do use qt for all my graphic work almost every day.

You might have upgraded from 10.11 and you may have not tried to recompile qt5 or qscintilla2 on 10.12 (or more precisely with Xcode8). Both are known to not compile, see e.g. However, patches have been proposed upstream. It's hopefully just a matter of days....

Help-octave mailing list

On one of my Macs, os 10.12 with Xcode 8 and Octave 4.0.3, I first did brew update , brew upgrade octave.  That worked fine.  

On the other Mac os 10.12 with Xcode 8 and Octave 4.0.3, I did
 brew update
brew uninstall octave
brew install octave 

That did not work because qt5 failed to install. 

I also just tried 

brew install octave --without-qt5  

It is still trying to install qt5.
==> Auto-updated Homebrew!
Updated 1 tap (homebrew/core).
==> New Formulae
archi-steam-farm                               consul-backinator                              hana                                         
==> Updated Formulae
android-ndk                 bazel                       efl                         git-extras                  openconnect               
==> Deleted Formulae
elementary                                                             evas-generic-loaders                                                 

==> Installing octave from homebrew/science
==> Installing dependencies for homebrew/science/octave: qt5, gnuplot, hdf5, imagemagick, tbb
==> Installing homebrew/science/octave dependency: qt5
==> Using the sandbox
Already downloaded: /Users/sunil/Library/Caches/Homebrew/qt5-5.6.1-1.tar.xz

So, most likely it will also fail.

brew formula seems to ignore the --without-qt5 flag.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]