[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues with xlsopen

From: PhilipNienhuis
Subject: Re: Issues with xlsopen
Date: Fri, 18 Nov 2016 23:47:49 -0800 (PST)

Steve Shearer wrote
> Hi,
> I am using Windows 7, I have JRE installed and I have Excel 2010.
> I have Octave V 4.2.0, and I have installed  io-2.4.5.tar.gz
> I have loaded io
> I am trying to read an xlsx file using xlsread - this has worked very well
> for me in the past, but now for some reason is unable to open the file. It
> seems to be failing at the xlsopen so I tried explicitly to xlsopen the
> file.
> This is what I get....
>>> dd=xlsopen('Steve1.xlsx')
> Detected XLS interfaces: warning: xls2open: file Steve1.xlsx couldn't be
> unzipped
> warning: __OCT_spsh_open__: some elements in list of return values are
> undefined
> warning: called from
>     __OCT_spsh_open__ at line 85 column 7
>     xlsopen at line 314 column 30
> None.
> warning: xlsopen.m: no'.xlsx' spreadsheet I/O support with available
> interfaces.
> dd = [](0x0)
> I have looked around on the web for solutions to this issue, but most
> solutions refer to the java package which is now incorporated in v4.2.0 so
> they seem not to be relevant.
> I would really appreciate some guidance on this problem please.

OK some suggestions...:

Have you tried with another spreadsheet file?

There's a helper function for these things in the io package.
So what does

chk_spreadsheet_support ("", 3)

tell you?

What happens if you also load the windows package?

There have been some recent posts here and bug reports with workarounds for
several xlsread issues; did you see those?


View this message in context:
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]