[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: QT - undefined reference to feval

From: Mike Miller
Subject: Re: QT - undefined reference to feval
Date: Sun, 28 May 2017 07:55:11 -0700
User-agent: NeoMutt/20170113 (1.7.2)

On Sun, May 28, 2017 at 00:57:00 -0700, alexegin wrote:
> Yes, I can. When I run the following command from *CLI* or from *Octave*,
> compiling and linking runs without error (but I have an exception when run
> the binary):
> terminate called after throwing an instance of 'octave::exit_exception'
> This application has requested the Runtime to terminate it in an unusual way.
> Please contact the application's support team for more information.

Ok, that can be fixed easily with a try-catch.

> According to the gcc docs
> <> I tried
> to disable new ABI using the following comand in *.pro* file:
> QMAKE_LFLAGS += --with-default-libstdcxx-abi

That is not correct, that option is for configuring and building gcc
itself. LFLAGS is also probably not correct. Try the macro that the docs
describe: _GLIBCXX_USE_CXX11_ABI.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]