[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: imread fails with unknown datatype for Region option error

From: Kai Torben Ohlhus
Subject: Re: imread fails with unknown datatype for Region option error
Date: Fri, 1 Nov 2019 14:03:45 +0900
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.1.1

On 11/1/19 11:14 AM, Sagarmatha wrote:
> On Thu, Oct 31, 2019 at 11:23 PM Kai Torben Ohlhus <address@hidden
> <mailto:address@hidden>> wrote:
>     On 11/1/19 1:21 AM, Spilskinanke wrote:
>     > I found the solution to this error! If you open GNU Octave with the
>     > --traditional argument, this error occurs. I removed the
>     --traditional and
>     > opened Octave normally, and my images now load!
>     >
>     > I hope this is a problem that gets fixed in the near future. Very
>     annoying
>     > to have the --traditional argument actually cause problems when
>     importing
>     > matlab code, as my imread worked perfectly fine in matlab and
>     > non-traditional Octave.
>     >
>     > Now if only the publish function didn't cause a core dump...
>     >
>     This bumped thread suffers a lot from missing information.  Please post
>     a small but meaningful portion of your code, leading to any errors.
>     This includes any pictures (or similar small ones) you try to load and a
>     verbose explanation of your Octave (method of installation,
>     Distribution, snap, flatpak, ...) and used+loaded Octave Forge package
>     versions (see "ver") and which operating system you are using.  And as
>     you mention "--traditional", please explain in detail all your
>     modifications to the standard settings, as well.
>     Best,
>     Kai
> The code in question was a simple binding that read
> pic_1 = imread("drawing_bw.bmp");
> This is what would cause the region error without fail. This would occur
> on any script that ran the function imread, where imread is being
> called, regardless of what came before or after it. I've tested this
> with multiple tiny script files that only contained the imread function.
> Octave version is 4.4.1 and was installed using the dnf package manager;
> sudo dnf install octave
> and I did not install any additional packages with it. The only argument
> I had when opening Octave was --traditional. I'm on Fedora 30 64bit.

Thank you for the detailed answer.  Please keep the mailing list in the
CC, so others may benefit from our conversation as well and answer at
the bottom of the email (bottom-posting [1]) to facilitate our conversation.

Where can I find "drawing_bw.bmp"?  Or do you say it happens with any
possible BMP-file?  The following code works for me using Octave 4.4.1
on openSUSE 15.1 and GraphicsMagick 1.3.29 installed:

  pic_1_name = "w3c_home.bmp";
  pic_1_file = ...
    urlwrite ( ...

"";, ...
  pic_1 = imread(pic_1_file);
  imshow (pic_1);

The original post you refer to was:
> [...] get the same error:
> >> im = imread('mypic.jpg');
> error: __magick_read__: unknown datatype for Region option
> error: called from
>    __imread__ at line 131 column 24
>    imageIO at line 117 column 26
>    imread at line 106 column 30
> I have imagemagick installed (16-bit channel depth version).



reply via email to

[Prev in Thread] Current Thread [Next in Thread]