[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot start octave-5.1.0 on fedora 31, not found

From: nicolas neuman
Subject: Re: cannot start octave-5.1.0 on fedora 31, not found
Date: Mon, 16 Dec 2019 08:50:06 +0100

On Sun, Dec 15, 2019 at 11:50 PM Mike Miller <address@hidden> wrote:
On Sun, Dec 15, 2019 at 14:22:07 -0600, niconeuman wrote:
> Greetings,
> I recently updated Fedora from version 29 to 31. In version 29 I had
> Octave-4.4.1 running with no problem.
> After updating to 31, I have version 5.1.0 installed. When I try to run
> octave it gives the following errors:
> $ octave
> octave: no graphical display found
> octave: disabling GUI features
> /usr/local/bin/octave-cli-5.1.0: error while loading shared libraries:
> cannot open shared object file: No such file or directory
> I'm not sure if the graphical part is the problem (I had problems with the
> nvidia drivers but I think I fixed them). The libhdf5 is installed because I
> also have anaconda. But I'm not sure how to let octave know that.

The error says "/usr/local/bin/octave-cli-5.1.0", which implies to me
that you have compiled Octave yourself from source and installed it in
/usr/local. This is the copy of Octave that isn't finding the library.
Have you tried running /usr/bin/octave instead? If that works, consider
uninstalling the copy of Octave under /usr/local to avoid confusion.


Hi Mike, thank you for your response.
I don't remember exactly how I had installed it, because it was some time ago, but I couldn't use it and used 4.4.1 instead. But after the Fedora update the other versions were gone.
Anyway, I downloaded and recompiled it as instructed here (, and then it worked, both in command line mode and in graphics mode using \octave --force-gui
It was late last night, though, and I only checked it opened the GUI. Hope it works fine now!
Thank you very much!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]