[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Accessing Removable-Media

From: David Carter
Subject: RE: Accessing Removable-Media
Date: Sat, 28 Dec 2019 14:06:13 -0700

Hi Mike,


Thanks much for the response. Now allow me do display my ignorance and ask, how do I run Octave in devmode?




From: Mike Miller
Sent: Saturday, December 28, 2019 12:12 AM
To: David Carter
Cc: address@hidden
Subject: Re: Accessing Removable-Media


On Fri, Dec 27, 2019 at 14:44:59 -0700, David Carter wrote:

> The issue I am having is my inability to access the /media directory

> from Octave. I can access the directory from ubuntu and ultimately get

> to a USB flash drive without difficulty, but whenever I cd to /media

> in Octave, I get a “Permission Denied” message.


> I am a ubuntu novice, but it appears to me that the snap that

> installed Octave does not include the “removable-media” interface, and

> thus is preventing me from accessing the /media directory. The Octave

> snap interfaces are defined in /snap/octave/10/meta/snap.yaml which is

> mounted as “Read Only” and try as I might, I am unable to edit the

> file. I have tried all the usual remedies, sudo, chmod, chown, mount,

> etc.


> Any guidance or insight in how to edit snap.yaml, or another solution

> on how I can access my USB flash drive from inside Octave would be

> greatly appreciated.


I suspect you're probably right about the removable-media interface. It

works for me on Debian without that interface connected, but that's

possibly a feature of the way confinement is implemented. Many of the

restrictions are only effective on Ubuntu.


If you think it would be useful to have the removable-media interface

added to Octave, please open an issue on the octave-snap project

( It would be best if

you are able to demonstrate that it doesn't work as is, and does work if

you run in devmode.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]