[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: installation configure script says "Cannot find libgcrypt" although

From: Test User
Subject: Re: installation configure script says "Cannot find libgcrypt" although libgcrypt is installed
Date: Fri, 11 Sep 2015 22:57:11 +0000 (UTC)
User-agent: Loom/3.14 (

Profilsicherheit - Administrator <info <at>> writes:

> When I tried to install shishi version 1.0.2, configure gives me this error:
> > configure: error: Cannot find libgcrypt
> My output of locate libgcrypt:
> > /lib/x86_64-linux-gnu/
> > /lib/x86_64-linux-gnu/
> I tried to give the path to the configure-script of shishi via:
> > configure -with-libgcrypt-prefix=/usr/local/

I was just trying to compile shishi today and had the same problem
(which I solved) and another one that I am here to report.

The problem is the test for libgcrypt in the configure script. Look for
the section:
#include <gcrypt.h>
/* GCRY_MODULE_ID_USER was added in 1.4.4 and gc-libgcrypt.c
   will fail on startup if we don't have 1.4.4 or later, so
   test for it early. */
#if !defined GCRY_MODULE_ID_USER 
error too old libgcrypt

The constant GCRY_MODULE_ID_USER was *removed* in version 1.6, so
the test fais in newer versions. You have to modify the test so
that it will pass. I changed my test to:
#if !defined GCRY_MODULE_ID_USER && (GCRYPT_VERSION_NUMBER < 0x010404)

I don't know why they did not use GCRYPT_VERSION_NUMBER in the first
place. Perhaps that constant did not exist at that time.

For what it is worth , you can see,
which describes the removal of the constant.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]