[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Help-smalltalk] Cygwin?

From: François-Denis Gonthier
Subject: RE: [Help-smalltalk] Cygwin?
Date: Sun, 20 Apr 2003 02:12:50 -0400

Hello again :)

With a bit of cut&paste magic, I got i18n to compile.  Everything works fine
now.  I couldn't figure out what was wrong with the installed copy of the
Win32 headers I had.

But now I've go another error.

I may sound annoying but I figure that I'm not the only one trying to get
GNU Smalltalk to work with Cygwin.  I tried to load the browser with:

gst -qK browser/


"Scavenging... 93% reclaimed, done"
"Scavenging... 93% reclaimed, done"
Loading package BloxTK
Object: DLD error: requested module blox-tk was not found
SystemExceptions.CInterfaceError class(Exception class)>>#signal:
DLD class>>#addModule:
optimized [] in PackageLoader class>>#primFileInPackage:
PackageLoader class>>#primFileInPackage:
optimized [] in PackageLoader class>>#fileInPackages:
PackageLoader class>>#fileInPackages:
PackageLoader class>>#fileInPackage:
/usr/local/share/smalltalk/browser/ invalid scope resolution

I build 2.1 on Linux and it worked right away without fiddling with the
default configuration

-----Message d'origine-----
De : Bonzini [mailto:address@hidden
Envoyé : 19 avril 2003 18:40
À : François-Denis Gonthier
Objet : Re: [Help-smalltalk] Cygwin?

There seems to be a problem with your Win32 headers, unrelated to GNU
Anyway this is not very important, if you don't want to investigate use
make -k and
you'll nevertheless have a usable executable.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]