[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-smalltalk] Mac OS 10.3.7 compiling problem and solution, scope res

From: Derek Peschel
Subject: [Help-smalltalk] Mac OS 10.3.7 compiling problem and solution, scope resolution problem
Date: Sun, 6 Mar 2005 01:13:00 -0800
User-agent: Mutt/

Hi everybody,

I'm trying to experiment with GST, to see what kind of platform it is
for developing new programming and text-editing tools.  Mainly I wanted
to compare it with Squeak.  I would not say GST is working on my system yet.
As you can see from the subject, I have Mac OS 10.3.7.  I'm using GST 2.10.

I have run into two problems.  The first, which I think I've solved, is that
the blox-tk library can't be linked because there are unresolved symbols
relating to Tcl and Tk.  (I compiled Tcl and Tk 8.4.9 from source, and that
creates frameworks.  Using Apple's Tcl framework and compiling Tk doesn't 
work. Apple is missing some private headers.)  It turns out that the Makefile
generates the correct -framework flag for the linker, but the version
of libtool supplied with GST takes it away again.  My best solution so far is:

  - download libtool 1.5.14 (1.5.12 has a serious bug, and 1.5.10 is the
    version supplied with GST)
  - in the root directory of the unpacked libtool .tar.gz file:
    - configure
    - make
    - sudo make install
  - in the root directory of the unpacked gst .tar.gz file:
    - libtoolize --copy --force --automake
    - make clean
    - configure --with-tcl=/Library/Frameworks/Tcl.framework 
    - make
    - sudo make install

Perhaps a new release of GST could have the same upgrade more cleanly?

The second problem involves package loading.  I've run "make install"
in the GST root directory.  I want to be able to type

  gst -qK browser/

but it only works if I'm in the GST root directory.  Otherwise I get

Object: PackageLoader error: package not available: Browser
PackageLoader class(Object)>>#error:
[] in PackageLoader class>>#fileInPackages:
[] in PackageLoader class>>#extractDependenciesFor:onError:
PackageLoader class>>#extractDependenciesFor:onError:
PackageLoader class>>#fileInPackages:
PackageLoader class>>#fileInPackage:
/usr/local/share/smalltalk/browser/ invalid scope resolution

So it's finding the right file, it just can't load it.  I understand
how traditional Smalltalk loads, but I don't understand how GST's startup
process extends that.  You have an image and its path, a kernel path,
the package-loading .st and .xml files, modules and a module path,
and the namespace feature.  That's a large number of new concepts.

I assume the two problems aren't related, but I don't know for certain.

If I understood how namespaces worked, things might be clearer.  Even if I
load the browser correctly, I can't figure out what to type in the workspace
to inspect the browser class or open a new browser.

Thanks for your help.  Note I'm not subscribed to the mailing list,
so a Cc: might be helpful.

-- Derek

reply via email to

[Prev in Thread] Current Thread [Next in Thread]