[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-smalltalk] linking readline

From: Bram Neijt
Subject: Re: [Help-smalltalk] linking readline
Date: Tue, 3 Oct 2006 13:09:20 +0200

I don't have that problem and I can't understand what the problem should be.
Make sure you run configure after installing the readline development
files, maybe?

Just to keep this from being a useless mail, the following worked for me:

tla my-id 'yourname <your email address>' # if first-time tla user
tla register-archive address@hidden
tla get -A address@hidden smalltalk--devo--2.2
find -type d -name autom4te.cache -print0 | xargs -0 rm -rf \;
find -type f \( -name missing -o -name install-sh -o -name mkinstalldirs \
       -o -name depcomp -o -name -o -name configure \
       -o -name config.sub -o -name config.guess \
       -o -name \) -print0 | xargs -0 rm -f
autoreconf --force --install
ldd gst
#Should now mention something like:
# =>  (0xffffe000)
# => /lib/tls/i686/cmov/ (0xb7f7b000)
# => /lib/ (0xb7f4c000)
# => /lib/tls/i686/cmov/ (0xb7e1b000)
# => /lib/tls/i686/cmov/ (0xb7e05000)
# => /lib/tls/i686/cmov/ (0xb7de0000)
#        /lib/ (0xb7f9f000)
# => /lib/ (0xb7d9d000)

Which shows it linked to readline.

Hope this helpes. If you think there are more problems, just send
another mail :-)

PS I've included a simple script I found on my system.

On 10/3/06, Brad Watson <address@hidden> wrote:
Not sure if I configured gst 2.2a improperly, but when
I ran ./configure --with-readline=/lib and attempted
to build gst (after I realized I needed the
libreadline dev files and installed them,) it couldn't
resolve the libreadline functions during linking.
When I hardcode -lreadline as one of the values to the
LIBS variable in the top-level Makefile, it compiled

Description: Bourne shell script

reply via email to

[Prev in Thread] Current Thread [Next in Thread]