[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-smalltalk] GNU Smalltalk 2.3 released

From: Brad Watson
Subject: Re: [Help-smalltalk] GNU Smalltalk 2.3 released
Date: Tue, 5 Dec 2006 13:17:25 -0800 (PST)

It still happens for me as well: xemacs just hangs when called from the 
./configure script in batch mode if it can't find the comint.el file.  On my 
system I do have the comint.elc file, and if I comment out the test for the 
former, the configure script runs fine.

----- Original Message ----
From: Paul D. Fernhout <address@hidden>
To: address@hidden
Sent: Tuesday, December 5, 2006 1:08:14 PM
Subject: Re: [Help-smalltalk] GNU Smalltalk 2.3 released


Thanks for this release. Just checked it into a local svn repository for 
some "experiments". :-) [Cue "Young Frankenstein"-ian laughter; see 
previous posts for details related to using pinches of GST to add 
something sweet to a certain bitter hot beverage. :-)]

Anyway, I tried to compile 2.3 as-is on a Debian system (mostly running 
testing). I am getting the same problem Brad Watson posted to the list 
about for 2.2, where he wrote:
 > I'm working on compiling and installing Smalltalk
 > 2.2a, however, I encountered a problem with the probe
 > for comint.el in the configure script: it halts
 > indefinately until I C-c out of it.

You asked him to run two commands (on 09/25/2006 11:25 AM), just for 
reference I ran them and got:

   $ emacs -batch -q -no-site-file -l comint.el
   bash: emacs: command not found

   $ emacs -batch -q -no-site-file -l comint.elc
   bash: emacs: command not found

This is probably around the spot in the configure code that hangs:

{ echo "$as_me:$LINENO: checking for comint.el" >&5
echo $ECHO_N "checking for comint.el... $ECHO_C" >&6; }
if test "${ac_cv_emacs_comint+set}" = set; then
   echo $ECHO_N "(cached) $ECHO_C" >&6

   if test $EMACS != no; then
     $EMACS -batch -q -no-site-file -l comint.el 2>&1 | \
       grep 'Cannot open load file' > /dev/null 2>&1 || ac_cv_emacs_comint=yes
     $EMACS -batch -q -no-site-file -l comint.elc 2>&1 | \
       grep 'Cannot open load file' > /dev/null 2>&1 || ac_cv_emacs_comint=yes

{ echo "$as_me:$LINENO: result: $ac_cv_emacs_comint" >&5
echo "${ECHO_T}$ac_cv_emacs_comint" >&6; }

I commented out that part out after the first two lines and it proceeds; I 
don't know enough of that scripting to understand if my commenting out 
broke anything important needed later for the build.

I typed "make" afterwards and it completed OK and then ran:
   $ ./gst
   GNU Smalltalk ready
   st> 2 + 3 !

Anyway, this is not a major problem for me; just thought I'd report it as 
an issue, especially if anyone else encounters it. Might just be what 
happens when emacs is not available?

Otherwise, congratulations on the milestone!

--Paul Fernhout

Paolo Bonzini wrote:
> GNU Smalltalk 2.3 is now available from the GNU FTP server:

help-smalltalk mailing list

Have a burning question?  
Go to and get answers from real people who know.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]