[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Help-smalltalk] Re: Compiling gst with mingw32

From: Akeroyd, FA (Freddie)
Subject: RE: [Help-smalltalk] Re: Compiling gst with mingw32
Date: Fri, 28 Sep 2007 14:18:02 +0100


I hadn't tried using Blox before but if you edit blox-tk/BloxTK.c and
change calls to index() to strchr() and then run configure as 

env LIBS="-ltk84 -ltcl84" ./configure --with-tcl=/mingw/lib

It seems to compile and link; i'm not sure why the default tcl libraries
are not picked up though

Once built you will need to copy   blox-tk/.libs/blox-tk-2-3-6.dll   to
 blox-tk.dll in the appropriate location; however when I run       

./gst browser/

I don't get a window, so further investigation is needed. 

With regard to "help2man" I can run 

make gst.1

OK from the doc directory, so I'm not sure what the cause of the problem
is there



-----Original Message-----
From: Cesar Rabak [mailto:address@hidden 
Sent: 28 September 2007 01:24
To: Akeroyd, FA (Freddie)
Cc: address@hidden
Subject: Re: [Help-smalltalk] Re: Compiling gst with mingw32

2007/9/27, Akeroyd, FA (Freddie) <address@hidden>:
> Hi,
> If you unpack a clean 2.3.6 distribution, cd into the top directory
> apply the enclosed patch via
> patch -p0 < mingw.patch
> touch aclocal.m4 configure
> It should fix the problems. You may get a warning about automake-1.9
> being available when you "configure and make", but you can ignore
Hi Freddie,

Your patch fixed the problems and gave the warnings as you predicted!

I had a small stumble on the building of docs (help2man has the path
for perl hardcoded and in a mingw32 installation it is available in
the binary path).

However, even if after I tried calling manually doing 'perl
../build-aux/help2man... etc., it failed saying help2man could not get
--help from gst.

After that, make complained I have not autom4te (which is true, but
configure did not complain earlier).

I was able to run make check and now I installed it with make install.

Present status: command line gst seems to be working (will test more
thoroughly tomorrow) but even though I compiled using:
./configure --with-tcl=/mingw/lib/ --with-tk=/mingw/lib

And I have a tcl and a tk in my mingw32 installation, as well as the and there, I could not run Blox.


Cesar Rabak

reply via email to

[Prev in Thread] Current Thread [Next in Thread]