[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-smalltalk] (no subject)

From: Paolo Bonzini
Subject: Re: [Help-smalltalk] (no subject)
Date: Sun, 03 Feb 2008 09:49:32 +0100
User-agent: Thunderbird (Macintosh/20071031)

I have only ever found zip useful in contexts with an arbitrary number
of arrays to zip.

I see.  That would be a kind of transpose operation.

That, and even though my naming skills haven't
improved, maybe #zip:zip:... would be a better naming convention to
describe this operation?

The #with: naming derives from SequenceableCollection>>#with:do:.

'123' with: '456' do: [ :a :b | (a, b) printNl ].
('123' with: '456') do: [ :ab | ab join printNl ].

I would like the Number methods in the stable series.

Thanks for the feedback.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]