[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-smalltalk] GNU smalltalk command line interpreter

From: bblochl2
Subject: [Help-smalltalk] GNU smalltalk command line interpreter
Date: Tue, 26 Feb 2008 14:06:27 +0100
User-agent: Thunderbird (X11/20070801)

I have a real dummy question! Beside other "smalltalks" I actually tried
GNU Smalltalk under OpenSUSE 10.3 on an AMD XP Machine:

localhost:~> gst -v
GNU Smalltalk version 2.1.12
Copyright 2003 Free Software Foundation, Inc.
Written by Steve Byrne (address@hidden) and Paolo Bonzini (address@hidden)

GNU Smalltalk comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of GNU Smalltalk under the terms of the
GNU General Public License.  For more information, see the file named

Using default kernel path: /usr/share/smalltalk/kernel
Using default image path: /usr/share/smalltalk

The GUI (gst -qK browser/ works as usual for smalltalk." 'Hello,
world' printNl" in the worksheet gives the expected output in the
transcript window. I tried the example of the Tutorial
in the line interpreter as well (or is it not a command line interpreter?):

localhost:~> gst
GNU Smalltalk ready

st> 'Hello, world' printNl

But as one sees from that copy there happens absolutely nothing! That is
also true for "123456 printString",  "6 + 7"  and other trial inputs. If
this is not a line interpreter I argue that it is only possible to start
files with a "shebang" or “sharp-bang”?

Where is may error?

Thanks in advance for help and best regards


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]