[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-smalltalk] make failed for 3.1 on os x 10.4

From: Roman Glass
Subject: [Help-smalltalk] make failed for 3.1 on os x 10.4
Date: Sat, 21 Feb 2009 12:27:37 +0100


I have tried to install the stable version of gnu smalltalk 3.1. After it configured without any problems make failed with a syntax error.

  ../libtool: eval: line 1: syntax error near unexpected token `|'

/usr/bin/nm -p .libs/gstpub.o .libs/files.o .libs/gst-parse.o .libs/ lex.o .libs/str.o .libs/tree.o .libs/byte.o .libs/comp.o .libs/ sym.o .libs/dict.o .libs/oop.o .libs/opt.o .libs/save.o .libs/ cint.o .libs/heap.o .libs/input.o .libs/sysdep.o .libs/callin.o .libs/ xlat.o .libs/events.o .libs/mpz.o .libs/print.o .libs/alloc.o .libs/ security.o .libs/re.o .libs/interp.o ../lib-src/.libs/library.a ../ libffi/.libs/libffi.a ../snprintfv/snprintfv/.libs/libsnprintfvc.a | | /sw/bin/sed 's/.* //' | sort | uniq > .libs/libgst.exp

It's right before the sed command. I am not very familiar with libtool and tried to change the file at line 328: export_symbols_cmds="\$NM \$libobjs \$convenience | \ $global_symbol_pipe | \$SED 's/.* //' | sort | uniq > \$export_symbols"

Is the \$global_symbol_pipe just missing somewhere referenced in the file? But maybe I am just wrong ... Am I on the wrong track?

Thanks for the help!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]