[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-smalltalk] More success with VisualGST on OS X

From: Eli Green
Subject: [Help-smalltalk] More success with VisualGST on OS X
Date: Tue, 13 Oct 2009 12:19:35 +0200

Hi all,

When I run gst-browser as a normal user, I receive an error saying 'File error: 
Permission denied'. I have no idea where that comes from and I'm not really 
sure how to debug it. I think the problem is that this occurs before the Gtk 
MainLoop is executing, so the window can be created and displayed but no 
widgets are ever asked to draw themselves.

However, if I run gst-browser as root, everything works perfectly! The UI comes 
up very quickly and is immediately usable. There are some errors which I will 
attribute to VisualGST's relative immaturity.

Any suggestions on how I can determine where this permission error is occurring?

Lastly, I was able to install the Quartz theming engine for OS X by downloading 
the latest tarball (gtk-quartz-engine-0.2.tar.gz) from , installing the latest libtool 
from (placing BINDIR in my PATH) and configuring the theme like 

CFLAGS='-m32' LDFLAGS='-arch i386' ./configure 

After configuring, copy your official GNU libtool script OVER the libtool in 
the gtk-quartz-theme directory - the generated version is broken but the build 
works perfectly with the GNU version.

However, it is hideous. Buttons are drawn strangely, widgets overlap in 
terrible ways... absolutely awful. Much better to stick to clearlooks, which 
is, to my eyes, much nicer than Squeak, Pharo or VisualWorks on OS X.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]