[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-smalltalk] Can't use Blox on OpenSUSE

From: Mike S
Subject: Re: [Help-smalltalk] Can't use Blox on OpenSUSE
Date: Tue, 4 Mar 2014 22:46:31 +0000

Hi all and thanks for the replies.

On Tue, Mar 4, 2014 at 8:29 PM, Holger Hans Peter Freyther <
address@hidden> wrote:

> On Mon, Mar 03, 2014 at 11:11:40PM +0000, Mike S wrote:
> Hi,
> > Hi all. Great work on gst. It's really wonderful. It's small, it's fast,
> > has a c-interface, it's just great.
> yeah. Paolo created something really nice. I like the I/O model of
> GST so much more than pharo. :)

It's also 64 bit. Pharo/squeak is only 32bit.  And Lightning is fantastic,
so is the accurate, generational, incremental, compacting Garbage
Collector. All this and it only takes 1mb of memory! Amazing. A true gem.

> > Unfortunately, I can't use Blox. I made sure I had tcl/tk installed, and
> > tcl-devel and tk-devel too. I told the configure script --with-tcl and
> > --with-tk to both and and yet it won't work. I
> > tried building tcl/tk from source myself and telling the configure script
> > to use the and I built myself and yet it won't
> > work.
> What exactly doesn't work? configure claims that it can't find Tcl/TK?
> Or does GST fail to load the package with tcl/tk? If it is configure can
> you please take a look at config.log and search for the tcl/tk results?
It can't Tcl/TK as installed from the openSUSE repositories. Even when it
point it to it with --with-tcl and --with-tk

These are the contents of as per installed
from the openSUSE repositories

the config.log generated by ./configure was too long to paste

The only way i managed to get it to recognize find them was by compiling
tcl/tk myself and then pointing it to it in the build directory, it said in
the config.log that it found them but it still gave me an error when i
tried to start gst-blox. What's more, the tcl/tk i got wasn't anti-aliased
as the one installed from the openSUSE directory was.

> > Is it possible to use it without Bloxtk, from the command line? I don't
> > want to use GTK (actually, even that didn't work, even though I had the
> > cario libs installed). I like tcl/tk and I may be able to contribute to
> > bloxtk. I feel lost without a squeak/pharo like IDE though.
> What is the issue with GTK and VisualGST? The tooling is squeak/pharo is
> really great and we have a lot to catch up. My current focus is improving
> the VisualGST debugger support (in the last months we already gained full
> view of all variables, restarting a method/frame, fixes to step over and
> step into, etc.). The next big thing would be to figure out how to get
> something like Monticello/Filetree into VisualGST and combine the power
> of having something like vi and grep but still do a lot of the development
> inside VisualGST/image.
I don't like GTK and Gnome. I think they're a sinking ship. Qt and KDE seem
to be the present and the future, and I'm sorry to be saying this given
that you work on GTK-based/VisualGST.

You know, I had an idea today. Why not use Pharo as a front end for Gnu
Smalltalk? Perhaps it'd be possible to replace the guts of pharo with gst
and use what's built on top for gst.

> >
> > Is it possibly to use GST entirely from the REPL? without any GUI? what
> > methods do I need to find my way around? (for example, in python there's
> > dir() and help() and in ruby there's .methods and in tcl there's info).
> Sure. It is smalltalk after all.
>  something inspect. will print a representation of the object
>  something class selectors. will print all selectors
>  (something >> #selector) methodSourceString will print you the
>  method code
>  (something >> #selector) inspect will print the bytecode and some
>  other information about the CompiledMethod.
>  (something lookupSelector: #selector) in case you don't know in
>  which class #selector is defined.
Thanks. That's what I was looking for. Any more such tips?

Attachment: config.log
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]