[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-smalltalk] DBI.Connection call yields "Object: nil error: did

From: Mark Bratcher
Subject: Re: [Help-smalltalk] DBI.Connection call yields "Object: nil error: did not understand #atEnd" in ST 3.2.91-b98173d
Date: Sun, 30 Aug 2015 22:51:50 -0400
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.2.0


I believe I found the problem.

The socket is connecting fine. But digging into the connection code, I found that a `class new` operation now automatically calls the `initialize` method in 3.2.91-b98173d, but it does not do so in 3.2.5. This causes a problem in the MySQLPacket and MySQLInputPacket connection code and results in `MySQLInputPacket >> initialize` being called too early in `^(self new) stream: aStream ; initialize` inside of ` MySQLPacket class >> on: aStream`. It's called automatically on `self new` before the stream is set.


On 8/30/2015 2:13 AM, Holger Freyther wrote:
On 29 Aug 2015, at 23:53, Mark Bratcher <address@hidden> wrote:

The exact same connection works fine under Smalltalk 3.2.5. So it's not an 
authentication issue in my case. I tried it on a couple of different databases, 
each time working in 3.2.5, but the same error using 3.2.91-b98173d.

that is odd. The difference from 3.2.5 to master in dbd-mysql itself is that I 
commitTransaction/rollbackTransaction because the super class already had these

If it isn’t too much work for you could you do the following (once fro 3.2.5 
and once
for master):

* Use wireshark/tcpdump to record a packet trace of the GST/MySQL communication
(maybe change the PW to something different..)
* Show the code that was used
* And the exception?

kind regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]