[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

About the tar_1.34 tests

From: Xinkuan Yan
Subject: About the tar_1.34 tests
Date: Fri, 2 Sep 2022 16:09:29 +0800

Hello guys,

I got a question here.

I would like to enable the Yocto Ptest for 'tar', so I have to run the tar test first.

I do not have knowledge for the autohell, I just want the tar tests run and provide me with correct test results, so what should I do?

Please tell me how to start the test, I see it is under the folder -> tar-1.34/tests, a testsuite shell script along with many many units.


Actually, I have tried many ways, I tried with simplely running the tests/testsuite script on Ubuntu 20.04, It tells me 171 tests were run, 101 failed.

I do not think I did it in the right way, if not, why so many tests failed?

And I tried with running the configure script, it is under /tar-1.34/, first, then the Makefile command -> make check-local. Still, 100+ tests failed.

The two upper ways, I tried in Ubuntu, but if I do that on a raspberrypi4, running the linux distro generated by Automotive Grade Linux (just take it as yocto, they are the same thing, I think), the testsuite script jammed while running the 60: exclude wildcards, it did not fail or pass, just doing nothing for about 20 hours.

I must have some mistakes before running the tests.

Any help is appreciated,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]