[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[help-texinfo] Problem building TeXinfo on MSWindow 2000 + mingw

From: Vincent Belaïche
Subject: [help-texinfo] Problem building TeXinfo on MSWindow 2000 + mingw
Date: Fri, 26 Sep 2008 05:28:30 +0200
User-agent: Thunderbird (Windows/20080708)


I am new to this list, and I apologize if the following issue has already been raised. I could not find this by searching the archive.

I am trying to build TeXinfo version 4.13 on mingw (my OS is Windows2000).

1) Problem 1
First problem I met is that, during compilation of install-info, regex.h could not be found. After searching on the MinGW dicussion archive, I installed regex port to Mingw (with prefix = /usr, not /usr/local, otherwise the include path was not found). This solved the first problem

I indicate this on this list, because the configuration step did not output any problem report (like "you need to install regex", or "install-info will not be made nor installed, because you need to install regex for that").

So, I think that this is *also* a TeXinfo problem (configuration step should inform the user on what to do for installation to be possible)

2) Problem 2
Second problem I met, is that the link of ginstall-info.exe failed. I modified install-info/Makefile by hand to replace line


by line

LIBS = -lregex

This solved the second problem. This seems to be the same problem as problem 1, that is to say configuration step does not test for regexp.

3) Problem 3: I get this kind of compile error now:

make[3]: Entering directory `/home/Vincent/Install/texinfo-4.13/info'
gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I../gnulib/lib -I../gnulib/lib -DLOCALEDIR=\"/usr/local/share/locale\" -DINFODIR=\"/usr/local/share/info\" -DINFODIR2=\"/usr/local/share/info\" -g -O2 -MT man.o -MD -MP -MF .deps/man.Tpo -c -o man.o man.c
man.c:23:23: sys/ioctl.h: No such file or directory
make[3]: *** [man.o] Error 1
make[3]: Leaving directory `/home/Vincent/Install/texinfo-4.13/info'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/Vincent/Install/texinfo-4.13/info'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Vincent/Install/texinfo-4.13'
make: *** [all] Error 2

4) for information
Because I need only makeinfo, I tried to make + install only makeinfo. So I made a cd to makeinfo, and then typed make, followed by make install.

Make works. However when I compile a .texi it does work only if I give the full path to non-installed makeinfo.exe, and if I try to use the installed makeinfo.exe the .texi does not compile. It seems that installation of makeinfo cannot be made independently from TeXinfo other module installation. Is that normal ?


PS: Maybe it would be better with 4.13a. Which one is the more recent ? is 4.13a some alpha version preceding 4.13 ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]