[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [help-texinfo] how does one encode a middle dot? and other questions

From: Gavin Smith
Subject: Re: [help-texinfo] how does one encode a middle dot? and other questions
Date: Sun, 5 Apr 2015 16:58:29 +0100

On 5 April 2015 at 10:18, Benno Schulenberg <address@hidden> wrote:
> First, is there a way to encode U+00B7 (middle dot) in a texi
> file, in a way similar to @guillemetright{} and @bullet{}?
Either use the character itself directly in the encoding of the file,
or the upcoming release has a new command @U so you could do @U{00B7}
- for Info output this gives the centre dot for UTF-8 output only.

> Second, in the manual it says that @documentencoding sets the
> input encoding.  But I find that an @guillemetright{} only gets
> rendered as "ยป" (instead of ">>") when I set @documentencoding
> to UTF-8.  So it's more like that command sets the output encoding,
> no?

>From the latest revision of the manual: "The '@documentencoding'
command declares the input document encoding, and can also affect the
encoding of the output."

> Sixth, how do I run texi2any without installing it?
> Running tp/texi2any fails with:
> Can't locate Texinfo/Convert/ in @INC (@INC contains: 
> /usr/local/share/texinfo/lib/Text-Unidecode/lib 
> /usr/local/share/texinfo/lib/Unicode-EastAsianWidth/lib 
> /usr/local/share/texinfo/lib/libintl-perl/lib /etc/perl 
> /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 
> /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 
> /usr/local/lib/site_perl . /usr/local/share/texinfo) at tp/texi2any line 106.
> BEGIN failed--compilation aborted at tp/texi2any line 106.
Doing "cd tp" first has always worked for me. I haven't researched how
to get it to run as "tp/texi2any". A related problem that has caught
me out several times is trying to run an installed makeinfo (e.g.
"/usr/local/bin/makeinfo") when the present working directory is "tp"
in the source directory - it will use the modules from the source
directory (which may have uninstalled modifications) instead of the
installed modules.

> (By the way, the gluing together of "failed--compilation" is ugly.)
AFAIK this is a Perl error message.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]