[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [help-texinfo] No index in PDF manual

From: Gavin Smith
Subject: Re: [help-texinfo] No index in PDF manual
Date: Sat, 30 Mar 2019 22:43:19 +0000
User-agent: Mutt/1.5.23 (2014-03-12)

On Sat, Mar 30, 2019 at 09:54:10PM +0000, Mohammad Akhlaghi wrote:
> Dear Texinfo developers,
> I just noticed that recently, the index of Gnuastro's PDF manual isn't
> created (see the last two pages of the output PDF below):
> However, it worked finely on my system until relatively recently (latest
> stable Gnuastro release, which I also built with `make pdf'):
> I must add that this problem doesn't happen in the Info manual (which
> contains an index).
> When I looked at the output of `make pdf' (attached `make-pdf.txt'), it
> says: "No file gnuastro.fns." and "No file gnuastro.cps.". So I guess the
> problem is in `texindex'. I have `texindex' installed (as part of Texinfo
> 6.6).

Hello Mohammed,

I downloaded the file you linked to and tried to build it, but there are 
several other files that it refers to.  I did manage to build the manual 
with the indices after I had edited the source to remove references to all 
the images and some of the included files.

I notice that it is the latest version of texinfo.tex that is being 
used.  I had never uploaded that version to; I expect 
somebody has got the file directly from the git repository.  In any 
case, it is useful that you are testing it.

It could be related to the change to use @ as the escape character in 
the index files.  Could you try running "texindex gnuastro.fn" and 
"texindex gnuastro.cp" and having a look at the contents of
gnuastro.cps and gnuastro.fns afterwards?  Then you could try running 
"pdfetex gnuastro.texi" to see if the PDF file is created with the 

Running "texi2pdf --verbose gnuastro.texi" might give more information 
about why texindex is not being run or not being run properly.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]