[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

address@hidden: Re: address@hidden: Re: [igraph] error while importing i

From: Gabor Csardi
Subject: address@hidden: Re: address@hidden: Re: [igraph] error while importing igraph]]
Date: Fri, 18 Apr 2008 22:38:45 +0200
User-agent: Mutt/1.5.13 (2006-08-11)

Jut for the records. It was Tamas, actually,

----- Forwarded message from Hernan Rozenfeld <address@hidden> -----

From: Hernan Rozenfeld <address@hidden>
To: Gabor Csardi <address@hidden>
Subject: Re: address@hidden: Re: [igraph] error while importing igraph]
Date: Fri, 18 Apr 2008 16:33:03 -0400

Dear Gabor,

Thank you so much for your response. I realized that I was in the  
folder of a different installation of igraph that never worked. I  
checked more carefully and fixed it.
After this I had another problem loading igraph but I fixed it by re- 
installing python. It seems (for what I read) that after installing a  
new xcode you are *supposed* to install python again (I have no idea  
why but this fixed everything).

Anyway, igraph runs amazingly fast and very smoothly now.

Thanks a lot!

On Apr 18, 2008, at 9:19 AM, Gabor Csardi wrote:

>You might miss messages if you're not signed up for the list.... FYI.
>----- Forwarded message from Tamas Nepusz <address@hidden> -----
>From: Tamas Nepusz <address@hidden>
>To: Help for igraph users <address@hidden>
>Subject: Re: [igraph] error while importing igraph
>Date: Fri, 18 Apr 2008 15:15:00 +0200
>Hi Hernan,
>><type 'exceptions.ImportError'>: dlopen(/sw/lib/python2.5/site-
>>packages/igraph/core.so, 2): no suitable image found.  Did find:
>How did you install igraph? There is a .mpkg installer for Intel Macs
>using Leopard, which can be downloaded here:
>Did you use this one? What I find particularly strange is the
>following two error messages in your output:
>>      /sw/lib/python2.5/site-packages/igraph/core.so: mach-o, but wrong
>This means that the C core of igraph is compiled for the wrong
>architecture (PPC instead of Intel or the opposite). Since you have an
>Intel-based Mac and I also compiled igraph for Intels, this shouldn't
>happen. Please examine the above mentioned file from the command line
>as follows:
>file /sw/lib/python2.5/site-packages/igraph/core.so
>This should list the architectures for which core.so was compiled. In
>my case, this looks like as follows:
>core.so: Mach-O universal binary with 2 architectures
>core.so (for architecture i386):        Mach-O bundle i386
>core.so (for architecture ppc7400):     Mach-O bundle ppc
>>      /usr/local/lib/core.so: stat() failed with errno=62
>I think errno=62 means that there are too many symbolic links the OS
>must follow when it tries to resolve the actual location of /usr/ 
>lib/core.so. Moreover, there shouldn't be any file named like this (at
>least not in igraph). So I think core.so belongs to a different
>library installed on your Mac and Python tries to load it only because
>it failed to load /sw/lib/python2.5/site-packages/igraph/core.so.
>Therefore, we should first figure out why Python fails to load it.
>igraph-help mailing list
>----- End forwarded message -----
>Csardi Gabor <address@hidden>    UNIL DGM

Hernan Diego Rozenfeld, Ph.D.

Steinman Hall, #1M
City College of CUNY
140th St. at Convent Ave.
New York, NY 10031

315-212-3449 (Cell)
212-650-8871 (Phone)
212-650-6835 (Fax)


----- End forwarded message -----

Csardi Gabor <address@hidden>    UNIL DGM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]