[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] ubuntu python package is broken?

From: Gabor Csardi
Subject: Re: [igraph] ubuntu python package is broken?
Date: Tue, 24 Jun 2008 03:26:28 -0500
User-agent: Mutt/1.5.17+20080114 (2008-01-14)


thanks for your report. However, I've just tried it with a virgin
installation and worked fine. 

I think the problem is that you still have the 0.4.5 version 
in /usr/local and python loads the C library from there. 
The C compilation against 0.4.5 is probably OK because you 
don't actually call any new 0.5 functions in your C program.

Please try removing your 0.4.5 installation, that should solve
the problem.


ps. please consider joining the list, anonymous posting is not 
allowed to avoid SPAM. If you're not a member then your messages
will be delayed, sometimes for minutes, sometimes for days....

On Tue, Jun 24, 2008 at 03:34:47AM -0400, Dhruv Bansal wrote:
> Hello,
> I'm running Ubuntu 7.10 and I added
> deb http://cneurocvs.rmki.kfki.hu /packages/binary/
> deb-src http://cneurocvs.rmki.kfki.hu /packages/source/
> to my /etc/apt/sources.list which allowed me to install libigraph,
> libigraph-dev, and python-igraph packages using apt-get.
> When trying to import the igraph module into the Python interpreter I
> get the following error:
> >>> import igraph
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
>   File "/usr/lib/python2.5/site-packages/igraph/__init__.py", line 30, in 
> <module>
>     from core import *
> ImportError: /usr/lib/python2.5/site-packages/igraph/core.so: undefined 
> symbol: igraph_authority_score
> I can write a C program and compile it against the igraph library from
> the packages like so
> g++ -ligraph -I/usr/lib/igraph my_igraph_program.c
> without any errors and compilation and execution for the C program are
> identical to when I compile against (an older) source version
> g++ -ligraph -I/usr/local/lib/igraph my_igraph_program.c
> where I'd previously installed version 0.4.5 of igraph into
> /usr/local.  (I was also able to build the Python wrapper against this
> older version of the source.)
> This seems to be a problem with the Python wrapper and not the actual
> C library.  Has anyone else had similar problems?
> Thanks!
> -- 
> Dhruv Bansal
> Department of Physics, UT Austin
> RLM 14.316 || (512) 471-0619 || address@hidden || http://www.dhruvbansal.com
> _______________________________________________
> igraph-help mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/igraph-help

Csardi Gabor <address@hidden>    UNIL DGM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]