[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] Installing igraph on Solaris

From: Jens Pfau
Subject: Re: [igraph] Installing igraph on Solaris
Date: Fri, 29 Jan 2010 17:24:15 +1100


You can find the assembly file here: http://ww2.cs.mu.oz.au/~pfauj/math.s
The error still occurs in line 96.

Somehow the assembler does not accept the -a option, so I cannot
create a mixed C/assembler listing. I don't know how useful the plain
assembly file is.

In the meantime I made the source code compatible with GCC 2.95.2 and
managed to compile it with this version of GCC (which somehow on this
machine is linked to a proper assembler). However, when I try to use
igraph from the python library, I get this error:

File "/home/pgrad/pfauj/local/lib/python/igraph/__init__.py", line 30,
in <module> from igraph.core import *
ImportError: ld.so.1: python: fatal: relocation error: file
/home/pgrad/pfauj/local/lib/libigraph.so.0: symbol
referenced symbol not found

I tried to compile with different versions of ld and with
--with-external-arpack but without success. The directory with
libigraph.so is on my $PATH and $LD_LIBRARY_PATH. I also tried to
start python with a preloaded libigraph. Any idea how to proceed on
that front?

Thank you very much for your help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]