[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] Problem installing igraph via R on FreeBSD 7.3 SOLVED

From: jim smith N0OCT
Subject: Re: [igraph] Problem installing igraph via R on FreeBSD 7.3 SOLVED
Date: Fri, 2 Jul 2010 09:21:45 -0500

Hi Gabor,

Thanks for all your help on this, but I still can't make it work.  See below.

On Fri, 2 Jul 2010 15:15:10 +0200
Gábor Csárdi <address@hidden> wrote:

> On Fri, Jul 2, 2010 at 3:08 PM, jim smith <address@hidden> wrote:
> > On Sat, 26 Jun 2010 19:39:20 +0200
> > Gábor Csárdi <address@hidden> wrote:
> >
> >> Jim,
> >>
> >> if the whole system was compiled with gcc 4.2, why not just compiling
> >> the packages with the same 4.2 compiler?
> >>
> >> Gabor
> >
> > Would I do that by specifying something in the igraph Makevars.in file
> > for igraph?  (Under igraph/src/Makevars.in).
> From the output of
> R CMD INSTALL --configure-args="--help" igraph
> Some influential environment variables:
>   CC          C compiler command
>   CFLAGS      C compiler flags
>   LDFLAGS     linker flags, e.g. -L<lib dir> if you have libraries in a
>               nonstandard directory <lib dir>
>   LIBS        libraries to pass to the linker, e.g. -l<library>
>   CPPFLAGS    C/C++/Objective C preprocessor flags, e.g. -I<include dir> if
>               you have headers in a nonstandard directory <include dir>
>   CXX         C++ compiler command
>   CXXFLAGS    C++ compiler flags
>   CXXCPP      C++ preprocessor
>   CPP         C preprocessor
> So just set the 'CC' and the 'CXX' environment variables.
> Best,
> Gabor

So I did this:

sudo R CMD INSTALL --configure-args="CC=gcc42 CXX=g++42 CPP=cpp42"  

. . .and it gets through the configure phase OK, with gcc42, g++42 and cpp42 
being specified.  Once it appears that configuration is complete it starts into 

** libs
g++44 -I/usr/local/lib/R/include  -I/usr/local/include   -DUSING_R -fpic  -O2 
-fno-strict-aliasing -pipe -Wl,-rpath=/usr/local/lib/gcc44 -c DensityGrid.cpp 
-o DensityGrid.o

. . .and continues to build with gcc44.  When  I start R and try to load the 
igraph library, this is the error I get:

> library('igraph')
Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared library 
  /usr/local/lib/R/library/igraph/libs/igraph.so: Undefined symbol 
Error : .onLoad failed in 'loadNamespace' for 'igraph'
Error: package/namespace load failed for 'igraph'

I do appreciate all your help and quick responses, but I think I'm wasting  
your time with basic C/C++ programming stuff that I just don't know.

jim smith N0OCT <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]