[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[igraph] Re: shared library error

From: sergiu netotea
Subject: [igraph] Re: shared library error
Date: Wed, 26 Jan 2011 11:15:55 +0100

Some further news,
I checked the content of $LD_LIBRARY_PATH and it was empty, so I added my path:
export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

Now my program ran but with a segmentation fault. However I got no seg
faults on cygwin :((
Not sure that I solved the shared library problem though, make it
chooses the wrong file, I saw three:
libigraph.so libigraph.so.0  libigraph.so.0.0.0

On Wed, Jan 26, 2011 at 11:03 AM, sergiu netotea
<address@hidden> wrote:
> Hi,
> I have a server running Red Hat Enterprize edition, I installed the
> igraph library from source code following the normal ./configure,
> make, make install steps. I have a program that runs well on my local
> cygwin, compiled with:
> gcc grn.c -Wall -I/usr/local/include/igraph -L/usr/local/lib -ligraph -o grna
> It does compile on the server without any message but when I run it, it gives:
> ./grna: error while loading shared libraries: libigraph.so.0: cannot
> open shared object file: No such file or directory
> However the libs are there, beside the fact that in the compilation
> step it managed to find them:
> ls /usr/local/lib
> libgsl.a  libgslcblas.a  libgslcblas.la  libgslcblas.so
> libgslcblas.so.0  libgslcblas.so.0.0.0  libgsl.la  libgsl.so
> libgsl.so.0  libgsl.so.0.15.0  libigraph.a  libigraph.la  libigraph.so
>  libigraph.so.0  libigraph.so.0.0.0  pkgconfig
> The include files are also in their place. I suspect it has to do with
> bad registration of the shared library. But why didn't I get any
> message at installation, or when I compiled my program?
> I wanted to check the cache of ldconfig but strangely enough the
> command is not available.
> Looking at this it all seems like a big hurdle and I don't have much
> time right now:
> http://www.faqs.org/docs/Linux-HOWTO/Program-Library-HOWTO.html#AEN115
> I am not very good at libtools, perhaps you can give me some help
> running my program? JJ
> Thanks!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]