[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] compiling igraph C under linux

From: Tamás Nepusz
Subject: Re: [igraph] compiling igraph C under linux
Date: Wed, 16 Feb 2011 00:14:53 +0100

> I tried to install the last nightly built igraph 
> (igraph-nightly-0.6-2340-20110215.tar.gz) under linux ubuntu this time...And 
> this below what I got back.
> Can I ask you what do you think of this?
Try building igraph as follows:

./configure --with-external-blas --with-external-lapack --with-external-arpack

(you'll have to install the BLAS, LAPACK and ARPACK packages from Ubuntu of 
This should do the trick until we sort out the problems with f2c (probably with 
tomorrow's nightly build).

> Just before I tried to run the igraph-0.5.4 and it compiled OK but afterward 
> I was unable to run the example of the tutorial igraph_test.c:
> http://igraph.sourceforge.net/doc/html/ch03s01.html
> Because typing:
>  gcc igraph_test.c -I/usr/local/include/igraph -L/usr/local/lib -ligraph -o 
> igraph_test
> I got back:
> Undefined reference to _intel_fast_memcpy and _intel_fast_memset

Have you used the Intel C Compiler recently to compile igraph by any chance? 
The igraph library does not refer to these symbols when I compile it on Ubuntu 
using gcc.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]