[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] plotting on ubuntu

From: Denzil Correa
Subject: Re: [igraph] plotting on ubuntu
Date: Wed, 21 Dec 2011 23:00:07 +0530

This worked for me.


On Wed, Dec 21, 2011 at 10:53 PM, Tamás Nepusz <address@hidden> wrote:

Indeed, this is a common issue and quite a misleading error message (which is likely to be fixed in igraph 0.6). The problem is that igraph is not able to find a suitable image viewer on your machine to show the generated plot. It can be worked around by creating a file called .igraphrc in your home and adding the following lines:

image_viewer = /usr/bin/whatever-image-viewer-you-use

igraph tries quite a few image viewers by default (see get_platform_image_viewer() in igraph/configuration.py for a list), but apparently your system has none of them. If you tell me which image viewer you use, I'll add it to the next release.


On 21 Dec 2011, at 18:17, Claudio Martella wrote:

> Hello list,
> I guess this must be a common issue. I've got igraph install on latest
> ubuntu with apt-get and pyigraph with pip. when i try to plot a graph
> with igraph.plot() that's what i get:
> /usr/local/lib/python2.7/dist-packages/python_igraph-0.5.4-py2.7-linux-x86_64.egg/igraph/drawing.pyc
> in plot(obj, target, bbox, *args, **kwds)
>    763     cw, ch = bbox.width/60., bbox.height/60.
>    764     result.add(obj, bbox.contract((cw, ch, cw, ch)), *args, **kwds)
> --> 765     if target is None: result.show()
>    766     if isinstance(target, basestring): result.save()
>    767     return result
> /usr/local/lib/python2.7/dist-packages/python_igraph-0.5.4-py2.7-linux-x86_64.egg/igraph/drawing.pyc
> in show(self)
>    406             # No image viewer was given and none was detected. This
>    407             # should only happen on unknown platforms.
> --> 408             raise NotImplementedError, "showing plots is not
> implemented on this platform: %s" % platform.system()
>    409         else:
>    410             os.system("%s %s" % (imgviewer, self._tmpfile_name))
> NotImplementedError: showing plots is not implemented on this platform: Linux
> what could it be?
> --
>    Claudio Martella
>    address@hidden
> _______________________________________________
> igraph-help mailing list
> address@hidden
> https://lists.nongnu.org/mailman/listinfo/igraph-help

igraph-help mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]