[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[igraph] Building and installing C-Core and Python Interface under windo

From: Winnie Kanje
Subject: [igraph] Building and installing C-Core and Python Interface under windows
Date: Tue, 20 Aug 2013 12:36:43 +0200

I have a question on building and installing Igraph with the python interface under Windows 7.
Just to rule it out from the beginning: I cannot use the prebuilt binaries, as I do not have root privileges.
My OS is Windows 7 64 bit,
I run Python 2.7 32 bit.

What I have tried so far:
I downloaded the igraph-c-core into a new directory C:\IGraph
I started a cygwin terminal and ran -/configure --prefix=C:\IGraph as I wanted the built to go into that directory as well
I ran make in cygwin and finally make install
Everything went fine so far. (At least after fiddling with that for 2 hours or so...)
At this point I assume the c-core of igraph was built and installed successfully.

So let's get to the python interface.
I downloaded the python-igraph zip file from PyPI and unpacked it into Python27/Lib/site-packages/python-igraph-0.6.5
I modified the setup.py file like the following:
LIBIGRAPH_FALLBACK_INCLUDE_DIRS = ['/usr/include/igraph', '/usr/local/include/igraph','C:\IGraph\include\igraph']

Then I ran python setup.py install and to me the installation ran successfully ( the last lines were:
Installed c:\python27\lib\site-packages\python_igraph-0.6.5-py2.7-win32.egg
Processing dependencies for python-igraph==0.6.5
Finished processing dependencies for python-igraph==0.6.5)

But now the funny thing comes:
When I try to import igraph into python using "import igraph" the shell keeps processing the command but never comes to an end. When I ran the command
python -v -c "import igraph" in the windows command shell the last line printed is
import _random # builtin

Can someone figure this out? I really have no ideas or clues left...
Thanks in advance

reply via email to

[Prev in Thread] Current Thread [Next in Thread]