[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] install w/anaconda?

From: David Robinson
Subject: Re: [igraph] install w/anaconda?
Date: Fri, 30 Aug 2013 11:27:27 -0600

> ________________________________
> I apologize for the installation question, but I've been moving from platform
> to platform to keep customers happy. Getting Python (and packages) loaded on
> the various Windows platforms drove me to the edge of insanity. I'm back on a
> Mac and I thought things were going to be simpler. The particulars are: Python
> 2.7.5 (via anaconda), OS X 10.7.5 (Lion). (Using the usual package
> installation route, I ran into scipy install problems no finding gfortran so I
> > just went with Anaconda. )
> > Anaconda is different in that the entire python system and packages are
> > installed relative to this python:
> > % which python
> > % /Users/drobin/anaconda/bin/python
> > This effective moves everything to ~/anaconda/bin, ~/anaconda/lib, etc.
> > Installers such as pip, brew, easy_install are still available, but the 
> > install
> > locations are relative to ~/anaconda .
> > I tried to adapt the instructions in the following message to my case:
> > http://lists.nongnu.org/archive/html/igraph-help/2012-07/msg00101.html
> > On the off-chance it will help, here is the output from running make on the
> > C-library:
> > ----snip---
> > On the one hand it feels like a path problem, but something else is amiss 
> > I'm
> > afraid.
> > Many thanks for any suggestions.
> > Dave

> Just in case someone else runs into this problem:
> I have successfully loaded igraph this morning by downloading and installing 
> a new version of libtool-2.4.2.tar, running ./configure & make & make install 
> within the libtool directory. I was then able to complete the igraph 
> installation using the steps outlined in the msg referenced above.
> [still have not run tests, but it imports to python without complaint.]

Well, the happiness was short-lived.  The re-install of libtool solved
one problem (igraph installation) but created a host of others that
the use of Anaconda had solved.  I'm back to my previous error
message.  Any additional suggestions about the installation of igraph
under Anaconda would be appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]