[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] Error importing igraph in OSX 10.10.5

From: Tamas Nepusz
Subject: Re: [igraph] Error importing igraph in OSX 10.10.5
Date: Wed, 4 Nov 2015 23:06:47 +0100

Hi Pablo,

Sorry, I was travelling in the last two weeks and I'm trying to catch
up with my backlog.

> Thank you for your response. I tried with Python 2.7.10 and Anaconda 2.3.0 
> but the result is the same. What do you think about installing Anaconda and 
> installing it from scratch?
I have no idea - feel free to try it as I managed to succeed with a
pristine installation of Anaconda Python 2.3.0 (as well as 2.1.0). If
that still doesn't work, and you have access to another Mac with OS X
10.9 or earlier, you could also try on that machine to see if it makes
a difference.

For what it's worth, __emutls_get_address (the symbol that the linker
is complaining about) corresponds to the emulation of thread-local
storage by gcc on Mac OS X. When igraph is installed using pip and you
don't have the C core of igraph installed from another source on your
machine, setup.py downloads the C core and compiles it *without*
thread-local support (i.e. it passes the --disable-tls option to the
./configure script), so there should be no reason for the linker to
link to anything related to thread-local storage - that's why I'm
quite confused why this error message appears for you.

A complete stab in the dark - this will probably not work, but I'm
running out of ideas now:

- try downloading python-igraph's source code from
- open setup.py, look for the only occurrence of "--disable-tls" and delete it
- run "python setup.py install" (of course via Anaconda Python)

All the best,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]