[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cannot commit ... sticky tags

From: Schwenk, Jeanie
Subject: cannot commit ... sticky tags
Date: Mon, 7 Jan 2002 17:12:44 -0800

I'm using cvs 1.11 on hpux.

I tagged the Aug 21 release with the tag Release_Aug21_2001.  Just a plain

While I was out for several weeks, the vendors who happen to be on the other
side of the world put a sticky tag on every file, including those I am
editing.  The tag for that is identical to the one I put on in August except
it is sticky.  But there do not appear to be any branches anywhere
associated with it (guess on my part).  There have been file modifications
since that particular release date on my side so I'm not sure if they have
the code from Aug 21 or the most recent.  I'm confused as to what the
'state' of everything is.

Today, as I go to check in several files, I did a cvs update.  No problem.
Then I tried to commit my changes and I got an error.  I'd fix the "above
errors first", but I don't know how to except my simply removing the sticky
tags.  Don't think that's the correct approach.

Here's the error, the cvs status and cvs log for one of the files in

cvs commit -m "lot history modifications"
cvs commit: sticky tag `Release_Aug21_2001' for file `' is not
a branch
cvs [commit aborted]: correct above errors first!

cvs status:
        File:    Status: Locally Modified

           Working revision:    1.12    Tue Dec 11 02:17:19 2001
           Repository revision: 1.12    filename,v
           Sticky Tag:          Release_Aug21_2001 (revision: 1.12)
           Sticky Date:         (none)
           Sticky Options:      (none)

Here's the log:
        Working file:
        head: 1.12
        locks: strict
        access list:
        symbolic names:
          Release_Aug21_2001: 1.12
          Release_Aug14_2001: 1.10
          SYSTEMA: 1.1.1
        keyword substitution: kv
        total revisions: 13;    selected revisions: 13

Can anyone tell me exactly what is going on?  Is there something I'm
missing?  What do I need to do to be able to commit files to the main trunk?
Obviously none of the other engineers here has tried to check in a file or
they'd all be in my cube.  It's not going to be a pretty site if I don't get
this fixed before one of them notices.  


reply via email to

[Prev in Thread] Current Thread [Next in Thread]