[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

commitinfo and chrooted cvs

From: Christian Kappel Jensen
Subject: commitinfo and chrooted cvs
Date: 8 Jan 2002 05:27:16 -0800


I have set up a chrooted ssh cvs server as instructed in the
Idealx-document with cvs 1.11.1p1 on a Linux Mandrake 8.0 and almost
everything seems to work fine.

I would like to be able to use the commitinfo file to execute a script
at every commit. My commitinfo file contain the line


However, I get the following error when I try to commit something on
the server:

cvs server: cannot exec / No such file or directory
cvs server: Pre-commit check failed
cvs [server aborted]: correct above errors first!

I know that it finds the script, since an empty
file creates another error. I have tried with variations in the script
- the simplest just trying to execute a static linked program
(actually ldd - just for test purposes) - but the above error keeps on
I use paths relative to the chrooted environment but have also tried
with absolute paths.

Has anyone succesfully used commitinfo with a chrooted cvs - and if
so, what could I be doing wrong?

  - Christian Kappel Jensen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]