[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "it is in the way" problem

From: Michael Sims
Subject: Re: "it is in the way" problem
Date: Fri, 25 Jan 2002 06:58:23 -0600

At 12:19 AM 1/25/2002 -0600, Jason Allen wrote:
I have my CVS repository all setup and working but occasionally I am seeing some really strange errors. Every once in a while when doing an update I get a whole bunch of "move away file X, it is in the way" errors.

One not-so-obvious cause for this error occurred with my development team not too many days ago.

We are developing a PHP-driven website using CVS for versioning. I develop on an Apache server running on Linux, and another team member develops on Windows/IIS. The other day she started getting the error you're talking about. Since she didn't have any uncommitted changes, we dropped the module out of her sandbox completely and re-checked it out. Still got the same error. I went to my sandbox and did the same thing without any problems.

Turns out that on my sandbox I had created a new file that had the same name as another file with a different case. For example, the repository contained "button.gif" and I had added a file called "Button.gif". Of course on Linux this is perfectly legal so I wasn't aware there was a problem. On Windows as soon as the CVS client tried to create "Button.gif" Windows said "that file is already here".

Anyway, to fix I renamed the file (obviously). This may not have anything to do with what you are doing but I thought I'd share just in case.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]