[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Help: Linux CVS Server Access Problem

From: Hill, Benjamin W
Subject: RE: Help: Linux CVS Server Access Problem
Date: Mon, 9 Jun 2003 09:05:10 +0100

That gleans the same result as a: "telnet [SERVERNAME]".



-----Original Message-----
From: Danny Sauer [mailto:address@hidden 
Sent: 06 June 2003 17:38
To: address@hidden
Cc: Hill, Benjamin W
Subject: RE: Help: Linux CVS Server Access Problem

You might try (from the client machine that's having problems):

telnet [SERVERNAME] 2401

If that works (ie, it doesn't reject your connection), try typing


Hit return (yes, forcefully strike the key) after each line.  It should tell
you that it hates you, and close the conenction (because the password isn't
properly encrypted and you hopefully don't have any user called "username").

You probably will get stopped at the telnet part, though, since you probably
have something rejecting connections on the server box.  Check to see that
xinetd isn't set up to block connections from hosts other than localhost,
and that tcp wrappers (if used) isn't rejecting connections to the CVS
service.  Make sure that the LISTEN entry in netstat is listening on all
relevent addresses (probably *:cvspserver), too.


Hill, Benjamin W said:
> Hi,
> I have been through the troubleshooter, but not found anything I 
> haven't tried.
> When I try to connect to the server from a Windows machine using:
> set cvsroot=:pserver:address@hidden:/cvs/repository
> cvs login [USERNAME]
> ..I get the line:
> "CVS password:"
> ...but when I enter a password I get:
> "cvs [login aborted]: connect to [SERVERNAME]([SERVERNAME]):2401 
> failed: No connection could be made because the target machine 
> actively refused it."
> I have checked that the cvspserver file is in /etc/xinetd.d and that 
> there is a LISTEN entry when doing a netstat.
> I can however log in from the Linux box itself using:
> export cvsroot=:pserver:address@hidden:/cvs/repository
> cvs login [USERNAME]
> ..and check out code etc. I will look at the pserver -f bit though!
> Cheers,
> Ben
> -----Original Message-----
> From: Jones, Larry
> Sent: 06 June 2003 16:17
> To: Hill, Benjamin W
> Cc: address@hidden
> Subject: Re: Help: Linux CVS Server Access Problem
> Hill, Benjamin W writes:
>> And I can authenticate, and then check out code in the repository 
>> fine. The problem is when I try to connect to the server remotely and 
>> do the same thing.
> See the troubleshooting advice in the manual:
>       <>
> If that doesn't help, feel free to ask for help, but at least tell us 
> exactly what the problem is!
>>         server_args         = --allow-root=/cvs/repository pserver -f
> The -f belongs before pserver, not after.
> -Larry Jones
> Oh, what the heck.  I'll do it. -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]